Hi,

Willem Jan Withagen wrote:
> I've just completed merging and patching with Anish patches...
> ONce that seems to run for my freebsd vm's, I'll start merging my
> patches. And hope that it still works.

Sounds good. I've tried some Linux versions ranging from 2.6.32, 3.10.x,
3.11.10 to 3.12.8 using an Anish's patched SVM+HEAD variant. They all
show the same behaviour being stucked during boot.

I haven't tried your patches yet, though.


> And best would be that the vlapic stuff gives a extra bit of speed,
> because we're not quite there yet.

I suppose you start your bhyved Linux instances using the "-A" switch (ACPI
tables), right? If you feel interested, you can try to start them without the
"-A" switch. For me, the boot process is now stucked at "Calibrating delay
loop". As far as I understand, it probably has something to do with a borked
"jiffies" value and that has probably something to do with a borked "IRQ 0"
that modifes that "jiffies" value at every tick.

But these are just wild guesses as I understand much too little about
kernels, virtualizing and stuff.

For what it's worth, using an Intel i3 and without the "-A" switch, the
bhyved Linux instance just boots fine as it does with the "-A" switch.

BTW: you haven't the oppurtunity to try bhyve SVN on a Barcelona- or later
class Opteron, have you?


Thanks again for all your work there. Looking forward to hearing your
results...



Regards,
Nils
_______________________________________________
freebsd-virtualization@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-virtualization
To unsubscribe, send any mail to 
"freebsd-virtualization-unsubscr...@freebsd.org"

Reply via email to