On Tue, Jul 29, 2014 at 12:48 PM, Glen Barber <g...@freebsd.org> wrote:

> On Tue, Jul 29, 2014 at 12:44:01PM -0700, Craig Rodrigues wrote:
> > Hi,
> >
> > I downloaded FreeBSD-11.0-CURRENT-amd64-20140714-r268622.vhd.xz
> > from
> >
> ftp://ftp.freebsd.org/pub/FreeBSD/snapshots/VM-IMAGES/11.0-CURRENT/amd64/20140714/
> >
> >
> > Under MacOS X, I uncompressed the .vhd.xz file.  I used VirtualBox, and
> > created a VM.  When I tried to attach
> > the .vhd file to this VM, VirtualBox gave this error:
> >
> >
> > Any ideas?
> There are a few issues with how qemu-img creates the VHD.  The use of
> qemu-img will very soon be not required, thanks to marcel@ adding VHD
> support to mkimg(1).
> In the meantime, can you try cloning the VHD disk, but instead of
> a dynamically-allocated image, set it to be a fixed-size image?  I have
> had very sporadic success with this, so cannot guarantee it will work.
> The VMDK image, however, should work without issue, if you are unable to
> get the VHD image to work.

I don't know how to clone the VHD disk.  Inside VirtualBox, I created a
FreeBSD VM with no disks,
and then attached the VHD image as a disk to this new VM.  It wasn't

However, I tried doing the same thing with the VMDK image, and that worked

If the new mkimg can create VHD files which import without problem into
VirtualBox, that will be a huge improvement.
freebsd-virtualization@freebsd.org mailing list
To unsubscribe, send any mail to 

Reply via email to