Without the extension pack, I couldn't create USB2.0 interface in my VM-s. So I tried to install it. First I found out, that there is an "installed"
version of it named VNC. After downloading it, I tried to install from
File / Preferences / Extensions / Add package. But it failed with an
error message about /dev/ctty. As I first tried as a normal user, next
I tried it as root. (xhost +local: ; VirtualBox). Now the installation
started, but failed with "Failed to locate the main module (VBoxPuelMain)" And after it I have a non-functional "Oracle VM VirtualBox Extension Pack". The difference between the original installed version and the failed version, is that the original has version the same version number with an _OSE postfix
in it.

Here is the full error message:

Failed to install the Extension Pack /home/zgabor/Oracle_VM_VirtualBox_Extension_Pack-4.3.16-95972.vbox-extpack.

Failed to locate the main module ('VBoxPuelMain').

Result Code: NS_ERROR_FAILURE (0x80004005)
Component: ExtPackManager
Interface: IExtPackManager {3295e6ce-b051-47b2-9514-2c588bfe7554}


So how can I enable USB 2.0 as it needs the extension pack?


Gábor < Gabor at Zahemszky dot HU >
freebsd-virtualization@freebsd.org mailing list
To unsubscribe, send any mail to 

Reply via email to