Hello,

El 02/05/15 a les 17.43, Roman Bogorodskiy ha escrit:
> Hi,
> 
> I'm trying to get Xen running and following these instructions:
> 
> https://wiki.freebsd.org/Xen
> 
> and
> 
> http://wiki.xen.org/wiki/FreeBSD_Dom0
> 
> I'm running two days old -CURRENT and ports. I've installed the
> emulators/xen port and followed instructions in pkg-message.
> 
> I'm having some problems with console. I'm wondering if it's possible to
> have X running on the same box running xen kernel?

It should be, although I had issues while using the vesa driver with a
FreeBSD Xen Dom0, mainly because Dom0 doesn't have access to the BDA and
EBDA, I'm working on fixing this in Xen upstream.

> My setup is as follows:
>  
>  - Intel i5-4690 that supports IOMMU:
>     $ sudo acpidump -t|grep DMAR
>       DMAR: Length=128, Revision=1, Checksum=90,
>     $
>  - vm.max_wired=-1 in /etc/sysctl.conf
>  - xc0     "/usr/libexec/getty Pc"         xterm   on  secure in
>    /etc/ttys
> 
> In loader.conf I have:
> 
> xen_kernel="/boot/xen"
> xen_cmdline="dom0_mem=2048M dom0_max_vcpus=4 dom0pvh=1 com1=115200,8n1
> guest_loglvl=all loglvl=all console=com1"

So you are trying to use the serial console but you are not getting any
output? If that's not the case, please drop the com1 parameter and set
console=vga.

Do you have anything else in your /boot/loader.conf apart from this two
lines?

> 
> With this setup I get my system booted and at some point I can see a
> login screen. When I type 'startx' the system freezes. Have to hard
> reboot it to get working again.

On which device do you get a login prompt? Is it xc0, ttyv0 or ttyu0?

Roger.

_______________________________________________
freebsd-virtualization@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-virtualization
To unsubscribe, send any mail to 
"freebsd-virtualization-unsubscr...@freebsd.org"

Reply via email to