I’ve been poking at using docker to run some linux apps.  In doing so, I’ve 
been looking at a couple features that I cannot tell if they’re failing, or 
just not implemented, or if there’s some other reason that it isn’t working.

The two options I’ve tried sofar that haven’t seemed to have any effect are 
these -v & -u.
docker run -i -v /tmp:/mnt —name=test centos
docker exec -u testuser test /bin/sh

I’ve been using the centos docker image as a basis for trying a few things, so 
the paths used in the -v command exist, both the path specified for the host, 
as well as that for the jailed guest.  In the case of the user flag, -u, the 
user definitely exists in the guest.  If I run a program which will run for a 
bit, and check the hosts’s “ps aux” list, the user it runs as is root, rather 
than the user/userid I specified.

I’m mostly just curious if these parameters aren’t implemented, or if I’m 
trying something wrong.


freebsd-virtualization@freebsd.org mailing list
To unsubscribe, send any mail to 

Reply via email to