Hi Evan,

 Thanks for persevering :)

[root@true11] /mnt/vm0/ds0/iso# pkg info | grep 7z
p7zip-15.14                    File archiver with high compression ratio

Unfortunately, it seems this version of 7z was not able to extract the
UDF ISO correctly.

I don't have that exact version of 2k12 but I was able to extract a 2k15 tp5 ISO and verify that it was the same with 7z 15.14 and the older 9.38 version. I'll try with some others and see how it goes.

I also added NetKVM drivers from this version virtio-win-0.1.102.iso,
not virtio-win-0.1.96.iso as was specified in the guide.

Glad to hear the newer version worked. The 0.96 version should also be fine.

My VM had a problem. It did boot and the SAC channels did start - but
somewhere after WIMApplyImage message was displayed in the SACSetupAct
- the VM would hang and top would show the bhyve process at 99% WCPU.
I destroyed the VM after it hanged like this for 1 hour. It took some
guessing, but eventually I recalled reading somewhere - possibly on a
KVM/QEMU/Xen wiki page - that IOMMU is needed for more than 1 core.

Shouldn't be anything to do with the IOMMU. I have noticed that Windows installs on AMD machines require 2 or more vCPUs. Still working that one out.

I had difficulty at first with the network configuration. TrueOS has
ipfw enabled and I suspect it was originally blocking my RDP traffic.
Also, I did not have any successful network connections before I set
and loaded what's described in 21.7.7 Persistent Configuration:
https://www.freebsd.org/doc/handbook/virtualization-host-bhyve.html

At first, I attempted to RDP to an IP I had assigned from the SAC
channel using the i <#> <ip> <netmask> <gateway> command. This never
worked and I am not sure why. Eventually, I created a CMD channel,
then used ipconfig to determine that Windows had leased a different IP
via DHCP. Using RDP to reach the DHCP IP worked! Oddly, I did not see
the static IP I had set in SAC updated with the DHCP one - but I
checked later, and it was updated. I'm new to SAC and maybe this is
just one of it's quirks. Not a FreeBSD problem in any case, but
perhaps a stumbling block others on freebsd-virtualization may
encounter.

The AutoUnattend installation file specifies DHCP for config. If you want a fixed address, you should be able to get it either by modifying the AutoUnatted file prior to repack, or removing the DHCP config lines and configuring via SAC.

later,

Peter.

_______________________________________________
freebsd-virtualization@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-virtualization
To unsubscribe, send any mail to 
"freebsd-virtualization-unsubscr...@freebsd.org"

Reply via email to