Hi,

I should have mentioned at the start - the disk image system ran ZFS
as does the freebsd host. I tried to boot the image like this:

sh /usr/share/examples/bhyve/vmrun.sh -c 4 -m 4096M -t tap0 -d
disk.img diskimage

It loads the spash screen and tries to boot but then drops me to the
mountroot prompt after a screen or so of output:



Trying to mount root from zfs:zroot/ROOT/default []...
Mounting from zfs:zroot/ROOT/default failed with error 5.

Loader variables:
 vfs.root.mountfrom=zfs:zroot/ROOT/default
Manual root filesystem specification:
   <fstype>:<device> [options]
         Mount <device> using filesystem <fstype>
                and with the specified (optional) option list.
                
                    eg. ufs:/dev/da0s1a
                            zfs:tank
                                    cd9660:/dev/cd0 ro
                                              (which is equivalent to:
mount -t cd9660 -o ro /dev/cd0 /)

 ?               List valid disk boot devices
   .               Yield 1 second (for background tasks)
     <empty line>    Abort manual input
mountroot> ? List of GEOM managed disk devices:
       gpt/zfs0 gpt/swap0 gpt/gptboot0 vtbd0p3 vtbd0p2 vtbd0p1 vtbd0

<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

I've tried various combinations for mountroot but I have no idea how
to make it see zfs:zroot/ROOT/default which is what it was on the
machine I got the image from.



mountroot> zfs:gpt/zfs0
Trying to mount root from zfs:gpt/zfs0 []...
Solaris: NOTICE: Cannot find the pool label for 'gpt'
Mounting from zfs:gpt/zfs0 failed with error 5.

mountroot> zfs:gpt/gptboot0
Trying to mount root from zfs:gpt/gptboot0 []...
Mounting from zfs:gpt/gptboot0 failed with error 2: unknown file system.

mountroot> zfs:zroot/gptboot0
Trying to mount root from zfs:zroot/gptboot0 []...
Mounting from zfs:zroot/gptboot0 failed with error 5.

mountroot> zfs:zroot/ROOT
Trying to mount root from zfs:zroot/ROOT []...
Mounting from zfs:zroot/ROOT failed with error 5.

mountroot> ?

List of GEOM managed disk devices:
 gpt/zfs0 gpt/swap0 gpt/gptboot0 vtbd0p3 vtbd0p2 vtbd0p1 vtbd0
mountroot> zfs:/zfs0
 Trying to mount root from zfs:/zfs0 []...
 Solaris: NOTICE: Cannot find the pool label for ''
 Mounting from zfs:/zfs0 failed with error 5.
mountroot> zfs:zroot/gpt/zfs0
 Trying to mount root from zfs:zroot/gpt/zfs0 []...
 Mounting from zfs:zroot/gpt/zfs0 failed with error 2: unknown file
system.

mountroot> zfs:zroot/zfs0
Trying to mount root from zfs:zroot/zfs0 []...
Mounting from zfs:zroot/zfs0 failed with error 5.

<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

Please can anyone advise how to make the image boot?

many thanks,
--
J.
_______________________________________________
freebsd-virtualization@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-virtualization
To unsubscribe, send any mail to 
"freebsd-virtualization-unsubscr...@freebsd.org"

Reply via email to