Hi,

Thanks for this. Can you grab teh same information from Linux somehow?
I'd like to see what address space the ath NIC is allocated.

Thanks,


Adrian


On 31 October 2012 16:33,  <hu...@hush.com> wrote:
> Hello,
>
> I had a look at the PCI card. It looks like the manufacturer/OEM is "Anatel". 
> The following two strings are printed on the board:
> WN5301A-H1-V02
> KN160562*7
>
> There's a sticker on the card as well, showing
> HP P/N: 5188-3742
> Vendor P/N: WN5301A-H1
>
> I tried to search for these strings to see whether I could get more 
> information about the chips used, but I didn't find anything that looked 
> helpful to me (but I don't know much about wireless hardware.)
>
> I tried to do a verbose boot of my 9.0-RELEASE amd64 install by adding the 
> lines
> boot_verbose="YES"
> kern.msgbufsize="655360"
> to /boot/loader.conf - the latter line because it seemed like 
> /var/run/dmesg.boot and the output of the dmesg program were incomplete, but 
> even with this line, I assume the output still does not contain the whole 
> boot process.
>
> Also, I booted the 8.3-RELEASE i386 DVD, selected verbose boot, and once the 
> installed showed up, started a shell, saw that ath0 still was not attached 
> properly, and saved the output of dmesg (I hope this is what you wanted when 
> you told be to use a live CD. If not, please give me more detailed 
> instructions.) Booting 7.4-RELEASE i386 repeatedly results in a kernel 
> segfault. If you want, I can try other versions and/or install FreeBSD 
> instead of just working from the fixit shell, or try to re-download and burn 
> 7.4-RELEASE i386.
>
> I attached the two dmesg outputs to this mail, since they are rather large 
> and I assume people don't want that lengthy e-mails on the mailing list 
> (please let me know if I'm wrong.) Additionally, in case the attachments get 
> stripped, they are accessible via the following URLs:
> http://nopaste.info/fde038484e.html (/var/run/dmesg.boot of 9.0-RELEASE amd64)
> http://nopaste.info/93e73796cc.html (dmesg output of 8.3-RELEASE i386)
>
> Your help is very much apprechiated.
>
>
> On 31 October 2012 at 10:18 PM, "Adrian Chadd" <adr...@freebsd.org> wrote:
>>
>>On 31 October 2012 14:14,  <hu...@hush.com> wrote:
>>
>>> ath0: <Atheros 5413> mem 0xfdee0000-0xfdeeffff irq 16 at device
>>4.0 on pci2
>>> ar5212ChipTest: address test failed addr: 0x00008000 -
>>wr:0x00000000 != rd:0xffffffff
>>> ar5212Attach: hardware self-test failed
>>> ath0: unable to attach hardware; HAL status 14
>>> device_attach: ath0 attach returned 6
>>
>>Right, I wonder if that PCI address is actually valid.
>>
>>Are you able to do a verbose boot and record the dmesg to a file,
>>and
>>attach it here?
>>
>>Can you try an i386 live disk, see if it is any different?
>>
>>Maybe try 8.0 and 7.0-REL, see if it probe/attaches? The AR5413
>>support should have been there in 7.0.
>>
>>This is very likely a PCI bus reset/enumeration issue, rather than
>>an
>>ath(4) device issue.
>>
>>Thanks,
>>
>>
>>
>>Adrian
_______________________________________________
freebsd-wireless@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-wireless
To unsubscribe, send any mail to "freebsd-wireless-unsubscr...@freebsd.org"

Reply via email to