Hello Adrian,

So I figured the problem out.

This is how it went. I booted OpenSuSE and couldn't find the device as
well...

At that point I was sure that the problem is with my PC. I decided to
install the card in a PC that is running Windows. After start it
recognized new hardware but I did not have drivers, looking at
hardware information it showed correct values.

I then put back the card to the FreeBSD machine and started SuSE. The
card became correctly recognized by Linux, I booted FreeBSD and the
card was no longer visible (though this time devid value was correct),
switched to Linux and Linux did not see it as well. At that point I
took isopropyl alcohol and cleaned the connection, plugged it back and
FreeBSD is seeing it now.

That card was in that old PC for many years, so probably the
connection oxidized (or maybe just dirt built up - I'm no chemist).

In any case it looks like it was a layer 8 problem after all. I'm
sorry for bugging you.

Thanks,
Derek

Monday, December 3, 2012, 12:26:06 AM, you wrote:

> Hi,

> If it's not recognising the card then it's either a whacky PCI bus
> code problem, or the device is just plainly not being seen by the
> motherboard or BIOS.

> Can you try booting Linux and see if it sees the PCI device?


> Adrian


> On 2 December 2012 23:42, Derek Kulinski <tak...@takeda.tk> wrote:
>> Hello Adrian,
>>
>> I'm having some issues with a NIC card that worked fine in another
>> FreeBSD box (very old hardware - Celeron 366MHz :) that was running
>> version 8.
>>
>> The box died, and I decided to just move the card to recent machine
>> (running FreeBSD 9.1 RC3).
>>
>> Unfortunately the machine does not recognize the card, I asked on the
>> forum, and person trying to help me thinks that perhaps it is a bug:
>>
>> http://forums.freebsd.org/showthread.php?t=36099
>>
>> I thought initially that I couldn't see the card even in pciconf, but
>> seems like the card probably is:
>>
>> none3@pci0:4:0:0:       class=0x020000 card=0x3a131186 chip=0x00130000 
>> rev=0x01 hdr=0x00
>>     class      = network
>>     subclass   = ethernet
>>     cap 01[44] = powerspec 2  supports D0 D3  current D0
>>
>> I tried to follow his advice and changed value of AR5212_DEVID to
>> 0x0000 but that did not seem to do anything (I recompiled if_ath and
>> if_ath_pci).
>>
>> So I went further and modified ar5212Probe()
>> and put a printf() statement there (as a first instruction).
>> Unfortunately it doesn't look that the statement was ever called, or
>> at least I did not see anything in the logs.
>>
>> I decided to not file PR because there is still a possibility I might
>> be doing something wrong. I configured that old machine a while ago
>> and I no longer have access to it's contents :/
>>
>> The old machine was running i386 kernel, the new one is running amd64.
>> The new one has Gigabyte GA-H77-DS3H motherboard and the NIC in
>> question is D-Link, I belive DWL-G520.
>> --
>> Best regards,
>>  Derek                          mailto:tak...@takeda.tk
>>
>> -- I can see clearly now, the brain is gone...
>>



-- 
Best regards,
 Derek                            mailto:tak...@takeda.tk

What happens if you get scared half to death twice?

_______________________________________________
freebsd-wireless@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-wireless
To unsubscribe, send any mail to "freebsd-wireless-unsubscr...@freebsd.org"

Reply via email to