I have got D-Link DWA-140 Rev. B3.
The problem: it's not even recognised by the system.

Diag info:

# uname -a
FreeBSD sf1.local 9.1-RELEASE FreeBSD 9.1-RELEASE #0 r243825: Tue Dec  4 
09:23:10 UTC 2012     r...@farrell.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC 

# dmesg
ugen2.2: <D-Link> at usbus2

nothing else in dmesg.

# usbconfig -d 2.2 dump_device_desc
ugen2.2: <11n Adapter D-Link> at usbus2, cfg=0 md=HOST spd=HIGH (480Mbps) 
  bLength = 0x0012                                                              
  bDescriptorType = 0x0001                                                      
  bcdUSB = 0x0200                                                               
  bDeviceClass = 0x0000                                                         
  bDeviceSubClass = 0x0000                                                      
  bDeviceProtocol = 0x0000                                                      
  bMaxPacketSize0 = 0x0040                                                      
  idVendor = 0x2001                                                             
  idProduct = 0x3c15                                                            
  bcdDevice = 0x0101                                                            
  iManufacturer = 0x0001  <D-Link>                                              
  iProduct = 0x0002  <11n Adapter>                                              
  iSerialNumber = 0x0003  <1.0>                                                 
  bNumConfigurations = 0x0001

I've tried preloading runfw vie loader.conf - no result.
I've tried 9.1-RELEASE i386 also - no result.

Googling on the internet gave me the idea this device is based on RT2870.

freebsd-wireless@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-wireless-unsubscr...@freebsd.org"

Reply via email to