Yes, you can't have both ethernet and wireless up on the same L2
network like that; things will get confused.

Does it all work fine if you don't have ethernet configured?


adrian

On 15 March 2013 06:52, Joshua Isom <jri...@gmail.com> wrote:
> I got it all working after removing the driver from the kernelconfig and a
> few other tweaks. I'll post an ugly diff later when I can. I was able to get
> the network working only after I forced the wired down and commented out the
> rc.conf references. DHCP worked but no routing, not even the router. I don't
> know if it's a FreeBSD issue or not.
>
>
> Adrian Chadd <adrian.ch...@gmail.com> wrote:
>>
>> Did you remove ath/ath_hal/ath_rate_sample from your kernel config
>> file when you rebuilt?
>>
>> The default system ships with ath/ath_hal/ath_rate_sample compiled
>> into the kernel rather than as modules.
>>
>> Thanks,
>>
>>
>>
>> Adrian
>>
>>
>> On 14 March 2013 19:57, Joshua Isom <jri...@gmail.com> wrote:
>>>
>>> On 3/14/2013 9:20 PM, Adrian Chadd wrote:
>>>
>>>> Oh!
>>>>
>>>> http://wikidevi.com/wiki/TP-LINK_TL-WDN4800
>>>>
>>>> Silly me, I was reading the wrong number on my phone.
>>>>
>>>> Yes, 0x0030 is Osprey (AR9380.)
>>>>
>>>> kldload
>>>> if_ath_pci too. :-)
>>>>
>>>>
>>>>
>>>> Adrian
>>>
>>>
>>>
>>> Something weird happened.  My config has ath_pci listed, but then I get
>>> this.
>>>
>>>> [jri:~] root# kldload if_ath_pci
>>>> kldload: can't load if_ath_pci: Exec format error
>>>> [jri:~] root# file /boot/kernel/if_ath_pci.ko
>>>> /boot/kernel/if_ath_pci.ko: ELF 64-bit LSB relocatable, x86-64, version
>>>> 1
>>>> (FreeBSD), not stripped
>>>
>>>
>>>
>>> Other modules like ath return the standard "already loaded" message.
_______________________________________________
freebsd-wireless@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-wireless
To unsubscribe, send any mail to "freebsd-wireless-unsubscr...@freebsd.org"

Reply via email to