FreeBSD thinkbsd 9.1-RELEASE-p6 FreeBSD 9.1-RELEASE-p6 #0 r254716M: Fri Aug
23 18:56:54 UTC 2013     root@thinkbsd:/usr/obj/usr/src/sys/GENERIC  amd64
Intel Centrino Wireless-N 2200 (2x2 BGN)
iwn0@pci0:3:0:0:        class=0x028000 card=0x42228086 chip=0x08918086
rev=0xc4 hdr=0x00
    vendor     = 'Intel Corporation'
    class      = network
    bar   [10] = type Memory, range 64, base 0xf0c00000, size 8192, enabled


related: http://www.freebsd.org/cgi/query-pr.cgi?pr=180816&cat
using : https://github.com/seanbruno/freebsd-iwl
i was able to get the interfaces to show up

iwn0: flags=8803<UP,BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 2290
        ether 9c:4e:36:9b:f2:90
        nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
        media: IEEE 802.11 Wireless Ethernet autoselect mode 11b
        status: associated

then that :   ifconfig wlan0 create wlandev iwn0

wlan0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        ether 9c:4e:36:9b:f2:90
        nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
        media: IEEE 802.11 Wireless Ethernet autoselect (autoselect)
        status: no carrier
        ssid "" channel 6 (2437 MHz 11b)
        country US authmode OPEN privacy OFF txpower 3 bmiss 10 scanvalid 60
        bgscan bgscanintvl 300 bgscanidle 250 roam:rssi 7 roam:rate 1 wme
        bintval 0


So its getting there, but i'm unable to scan

root@thinkbsd:/root # ifconfig wlan0 scan
root@thinkbsd:/root # ifconfig wlan0 list scan
root@thinkbsd:/root # ifconfig iwn0 scan
ifconfig: unable to get scan results
root@thinkbsd:/root # ifconfig iwn0 list scan
ifconfig: unable to get scan results


# dmesg | egrep 'iwn0|wlan0'
iwn0: <Intel(R) Centrino(R) Wireless-N 2200> mem 0xf0c00000-0xf0c01fff irq
17 at device 0.0 on pci3
iwn0: iwn_read_eeprom_ht40: no entry for channel 100
iwn0: iwn_read_eeprom_ht40: no entry for channel 108
iwn0: iwn_read_eeprom_ht40: no entry for channel 116
iwn0: iwn_read_eeprom_ht40: no entry for channel 124
iwn0: iwn_read_eeprom_ht40: no entry for channel 132
iwn0: iwn_read_eeprom_ht40: no entry for channel 149
iwn0: iwn_read_eeprom_ht40: no entry for channel 157
wlan0: Ethernet address: 9c:4e:36:9b:f2:90
iwn0: iwn4965_load_firmware: timeout waiting for adapter to initialize,
error 35
iwn0: iwn_hw_init: could not load firmware, error 35
iwn0: iwn_init_locked: could not initialize hardware, error 35
wlan0: Ethernet address: 9c:4e:36:9b:f2:90
wlan0: Ethernet address: 9c:4e:36:9b:f2:90
iwn0: iwn4965_load_firmware: timeout waiting for adapter to initialize,
error 35
iwn0: iwn_hw_init: could not load firmware, error 35
iwn0: iwn_init_locked: could not initialize hardware, error 35



rc.conf has
ifconfig_wlan0="WPA DHCP"
wlans_iwn0="wlan0"
ifconfig_wlan0="WPA DHCP"
wpa_supplicant_enable="YES"
wlandebug_wlan0="scan+auth+assoc"

and in loader.conf i have
if_iwlfw_load="YES"
if_iwi_load="YES"
legal.intel_iwi.license_ack=1



am i doing something wrong? or is it not fully supported yet?
_______________________________________________
freebsd-wireless@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-wireless
To unsubscribe, send any mail to "freebsd-wireless-unsubscr...@freebsd.org"

Reply via email to