You  have to do an 'up' with that ifconfig create line, or run the
supplicant. The supplicant does the 'up' itself.


On 30 December 2013 15:09, Thomas Mueller <> wrote:
> from Toomas AAS:
>> Hello Adrian!
>> Thanks for the idea.
>> I tried with just "ifconfig wlan0 up". Indeed it seems that the "scan"
>> is redundant, as wlandebug output shows that a scan is started
>> immediately after I issue the "ifconfig wlan0 up" command. Alas, the
>> scan result is still the same as in my original message, and "ifconfig
>> wlan0 list scan" shows no results.
> Surprise that scan would occur gratuitously.  When I type
> ifconfig wlan0 create wlandev rsu0 wlanmode sta
> I don't get any scan.  But I can follow with
> wpa_supplicant -B -i wlan0 -c /etc/wpa_supplicant.conf
> and this connects or associates.  I still need
> dhclient wlan0
> or
> ifconfig wlan0 inet netmask
> route add default
> This is for Hiro H50191 USB-stick wireless adapter.
> Chipset is RTL8191SU, FreeBSD >= 10 device rsu.
> With re(4) bug, this is my only way for Internet access from FreeBSD on
> MSI Z77 MPOWER motherboard.
> Tom
> _______________________________________________
> mailing list
> To unsubscribe, send any mail to ""
_______________________________________________ mailing list
To unsubscribe, send any mail to ""

Reply via email to