The driver source is in sys/dev/ath/ and sys/contrib/dev/ath/ath_hal/ar9300/

I have all of the linux driver source and the atheros internal driver
source for their AP products but their desktop drivers are .. very
laptop specific and it's hard to get the driver source out of the
relevant group(s).



-a


On 9 April 2014 12:28, tzoi516 <tzoi...@gmail.com> wrote:
> Hi,
>
> Thanks for all of the help. Where is the driver source code? I'll submit
> a PR today.
>
> Thanks,
> Mike
>
> On 04/09/14 15:02, Adrian Chadd wrote:
>> Hi,
>>
>> The AR9565 is a relatively new chip that hasn't really been thoroughly
>> tested in FreeBSD. Laptop manufacturers have also gone and done some
>> rather silly things to save cost on the wireless NIC itself and I'm
>> not sure those patches / work arounds are in -HEAD.
>>
>> please file a PR with this problem complete with your pciconf -lv
>> output as above.
>>
>> Thanks!
>>
>>
>> -a
>>
>>
>> On 9 April 2014 05:40, tzoi516 <tzoi...@gmail.com> wrote:
>>> I'm using the GENERIC kernel. Want me to create a custom kernel?
>>>
>>> pciconf info:
>>>
>>> hostb0@pci0:0:0:0:    class=0x060000 card=0xfa401179 chip=0x0c048086
>>> rev=0x06 hdr=0x00
>>>     vendor     = 'Intel Corporation'
>>>     device     = 'Haswell DRAM Controller'
>>>     class      = bridge
>>>     subclass   = HOST-PCI
>>> pcib1@pci0:0:1:0:    class=0x060400 card=0xfa471179 chip=0x0c018086
>>> rev=0x06 hdr=0x01
>>>     vendor     = 'Intel Corporation'
>>>     device     = 'Haswell PCI Express x16 Controller'
>>>     class      = bridge
>>>     subclass   = PCI-PCI
>>> vgapci1@pci0:0:2:0:    class=0x030000 card=0xfa471179 chip=0x04168086
>>> rev=0x06 hdr=0x00
>>>     vendor     = 'Intel Corporation'
>>>     device     = 'Haswell Integrated Graphics Controller'
>>>     class      = display
>>>     subclass   = VGA
>>> hdac0@pci0:0:3:0:    class=0x040300 card=0xfa4d1179 chip=0x0c0c8086
>>> rev=0x06 hdr=0x00
>>>     vendor     = 'Intel Corporation'
>>>     device     = 'Haswell HD Audio Controller'
>>>     class      = multimedia
>>>     subclass   = HDA
>>> xhci0@pci0:0:20:0:    class=0x0c0330 card=0xfa401179 chip=0x8c318086
>>> rev=0x04 hdr=0x00
>>>     vendor     = 'Intel Corporation'
>>>     device     = 'Lynx Point USB xHCI Host Controller'
>>>     class      = serial bus
>>>     subclass   = USB
>>> none0@pci0:0:22:0:    class=0x078000 card=0xfa401179 chip=0x8c3a8086
>>> rev=0x04 hdr=0x00
>>>     vendor     = 'Intel Corporation'
>>>     device     = 'Lynx Point MEI Controller'
>>>     class      = simple comms
>>> ehci0@pci0:0:26:0:    class=0x0c0320 card=0xfa401179 chip=0x8c2d8086
>>> rev=0x04 hdr=0x00
>>>     vendor     = 'Intel Corporation'
>>>     device     = 'Lynx Point USB Enhanced Host Controller'
>>>     class      = serial bus
>>>     subclass   = USB
>>> hdac1@pci0:0:27:0:    class=0x040300 card=0xfa4d1179 chip=0x8c208086
>>> rev=0x04 hdr=0x00
>>>     vendor     = 'Intel Corporation'
>>>     device     = 'Lynx Point High Definition Audio Controller'
>>>     class      = multimedia
>>>     subclass   = HDA
>>> pcib2@pci0:0:28:0:    class=0x060400 card=0xfa401179 chip=0x8c108086
>>> rev=0xd4 hdr=0x01
>>>     vendor     = 'Intel Corporation'
>>>     device     = 'Lynx Point PCI Express Root Port'
>>>     class      = bridge
>>>     subclass   = PCI-PCI
>>> pcib3@pci0:0:28:2:    class=0x060400 card=0xfa401179 chip=0x8c148086
>>> rev=0xd4 hdr=0x01
>>>     vendor     = 'Intel Corporation'
>>>     device     = 'Lynx Point PCI Express Root Port'
>>>     class      = bridge
>>>     subclass   = PCI-PCI
>>> pcib4@pci0:0:28:3:    class=0x060400 card=0xfa401179 chip=0x8c168086
>>> rev=0xd4 hdr=0x01
>>>     vendor     = 'Intel Corporation'
>>>     device     = 'Lynx Point PCI Express Root Port'
>>>     class      = bridge
>>>     subclass   = PCI-PCI
>>> ehci1@pci0:0:29:0:    class=0x0c0320 card=0xfa401179 chip=0x8c268086
>>> rev=0x04 hdr=0x00
>>>     vendor     = 'Intel Corporation'
>>>     device     = 'Lynx Point USB Enhanced Host Controller'
>>>     class      = serial bus
>>>     subclass   = USB
>>> isab0@pci0:0:31:0:    class=0x060100 card=0xfa401179 chip=0x8c498086
>>> rev=0x04 hdr=0x00
>>>     vendor     = 'Intel Corporation'
>>>     device     = 'Lynx Point LPC Controller'
>>>     class      = bridge
>>>     subclass   = PCI-ISA
>>> none1@pci0:0:31:3:    class=0x0c0500 card=0xfa401179 chip=0x8c228086
>>> rev=0x04 hdr=0x00
>>>     vendor     = 'Intel Corporation'
>>>     device     = 'Lynx Point SMBus Controller'
>>>     class      = serial bus
>>>     subclass   = SMBus
>>> atapci0@pci0:0:31:5:    class=0x010185 card=0xfa401179 chip=0x8c098086
>>> rev=0x04 hdr=0x00
>>>     vendor     = 'Intel Corporation'
>>>     device     = 'Lynx Point 2-port SATA Controller 2 [IDE mode]'
>>>     class      = mass storage
>>>     subclass   = ATA
>>> vgapci0@pci0:1:0:0:    class=0x030200 card=0xfa471179 chip=0x129210de
>>> rev=0xa1 hdr=0x00
>>>     vendor     = 'NVIDIA Corporation'
>>>     class      = display
>>>     subclass   = 3D
>>> ath0@pci0:3:0:0:    class=0x028000 card=0x061211ad chip=0x0036168c
>>> rev=0x01 hdr=0x00
>>>     vendor     = 'Atheros Communications Inc.'
>>>     device     = 'AR9565 Wireless Network Adapter'
>>>     class      = network
>>> none2@pci0:4:0:0:    class=0x020000 card=0xfa401179 chip=0x10a11969
>>> rev=0x10 hdr=0x00
>>>     vendor     = 'Atheros Communications Inc.'
>>>     class      = network
>>>     subclass   = ethernet
>>>
>>>
>>>
>>>
>>> On 04/08/14 18:29, Adrian Chadd wrote:
>>>> hi,
>>>>
>>>> ok. Can you please do a pciconf -lv and attach it here?
>>>>
>>>> Oh. Erm, did you compile a kernel from source? is ATH_ENABLE_11N in your 
>>>> kernel?
>>>>
>>>> Do a 'sysctl dev.ath.0.txagg=1' and then paste the output in dmesg here.
>>>>
>>>>
>>>>
>>>> -a
>>>>
>>>>
>>>> On 8 April 2014 13:38, tzoi516 <tzoi...@gmail.com> wrote:
>>>>> OK, killed wpa_supplicant and downed wlan0 and ath0. After ifconfig ath0
>>>>> up I received a ton of these:
>>>>>
>>>>> ath0: ath_edma_rxbuf_alloc: nothing on rxbuf?!
>>>>> ath0: ath_edma_rxfifo_alloc: Q1: alloc failed: i=0, nbufs=128?
>>>>>
>>>>> received those about 20 times then this:
>>>>>
>>>>> ath0: ath_edma_recv_proc_queue: Q1: NULL bf?
>>>>>
>>>>> And now the top 2 are slowly scrolling.
>>>>>
>>>>> Mike
>>>>>
>>>>>
>>>>> On 04/08/14 16:03, Adrian Chadd wrote:
>>>>>> Right. It sounds like it's not associated.
>>>>>>
>>>>>> Try wlandebug +assoc and then run wpa_supplicant
>>>>>>
>>>>>>
>>>>>> -a
>>>>>>
>>>>>>
>>>>>> On 8 April 2014 12:21, tzoi516 <tzoi...@gmail.com> wrote:
>>>>>>> Sorry for another email, the errors are sporadic. I'm trying to find the
>>>>>>> ioctl errors that I get on shutdown.
>>>>>>> These are after logging in:
>>>>>>>
>>>>>>> ath0: ath_edma_recv_tasklet: sc_inreset_cnt > 0; skipping
>>>>>>> dhclient[1001]: send_packet: Invalid argument
>>>>>>> dhclient[1001]: send_packet: No buffer space available
>>>>>>> ath0: ath_edma_recv_tasklet: sc_inreset_cnt > 0; skipping
>>>>>>> dhclient[1001]: send_packet: No buffer space available
>>>>>>> dhclient[1001]: send_packet: Invalid argument
>>>>>>> dhclient[1001]: send_packet: Network is down
>>>>>>>
>>>>>>> Mike
>>>>>>>
>>>>>>> On 04/08/14 14:38, Adrian Chadd wrote:
>>>>>>>> Ah. Can you post the buffer errors you're seeing?
>>>>>>>>
>>>>>>>>
>>>>>>>> -a
>>>>>>>>
>>>>>>>>
>>>>>>>> On 8 April 2014 11:37, tzoi516 <tzoi...@gmail.com> wrote:
>>>>>>>>> On 04/08/14 14:23, Adrian Chadd wrote:
>>>>>>>>>> It should work fine on -10 and HEAD. Is it not working fine?
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> -a
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> On 8 April 2014 09:12, tzoi516 <tzoi...@gmail.com> wrote:
>>>>>>>>>>> I have a Toshiba Satellite S55-A5169
>>>>>>>>>>> This specific one:
>>>>>>>>>>> http://www.bhphotovideo.com/c/product/1024074-REG/toshiba_pskk6u_08c08t_s55_i7_4700mq_12gb_1tb_windows_8_1_15_6_silver.html)
>>>>>>>>>>>
>>>>>>>>>>> It has the Atheros combo Wi-Fi/NIC, and the Wi-Fi uses the AR9565. 
>>>>>>>>>>> For
>>>>>>>>>>> it to work I have to change the SATA Controller Mode in the BIOS 
>>>>>>>>>>> from
>>>>>>>>>>> "AHCI" to "Compatibility". I don't know if this information helps, 
>>>>>>>>>>> and
>>>>>>>>>>> it's the only AHCI setting I can tweak.
>>>>>>>>>>>
>>>>>>>>>>> Mike
>>>>>>>>>>> _______________________________________________
>>>>>>>>>>> freebsd-wireless@freebsd.org mailing list
>>>>>>>>>>> http://lists.freebsd.org/mailman/listinfo/freebsd-wireless
>>>>>>>>>>> To unsubscribe, send any mail to 
>>>>>>>>>>> "freebsd-wireless-unsubscr...@freebsd.org"
>>>>>>>>> With SATA controller mode set to Compatibility then it works, but a
>>>>>>>>> little wonky at startup - sometimes I'll have to run wpa_supplicant -i
>>>>>>>>> wlan0 -c /etc/wpa_supplicant.conf. Infrequently a buffer error 
>>>>>>>>> appears.
>>>>>>>>> With SATA controller mode set to AHCI then I can ifconfig wlan0 list
>>>>>>>>> scan and see available networks but I can't connect to any except for
>>>>>>>>> unprotected networks.
>>>>>>>>>
>>>>>>>>> I'm currently running FreeBSD 10.0-STABLE
>>>>>>>>>
>>>>>>>>> Mike
>>>
>>> _______________________________________________
>>> freebsd-wireless@freebsd.org mailing list
>>> http://lists.freebsd.org/mailman/listinfo/freebsd-wireless
>>> To unsubscribe, send any mail to "freebsd-wireless-unsubscr...@freebsd.org"
>
_______________________________________________
freebsd-wireless@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-wireless
To unsubscribe, send any mail to "freebsd-wireless-unsubscr...@freebsd.org"

Reply via email to