Recently I just wanna try the TDMA wireless network of FreeBSD. My network is
simple, just three computers, two connect by TDMA each other(one master, one
slave) and another computer connect the TDMA master computer by ethernet
port(wired).

For start, I just run the scripts  setup.tdma-master and
setup.tdma-slave(under /usr/src/tools/tools/net80211/scripts) on each TDMA
computer. These two scripts will create two tdma nodes with both bridged to
each wired NIC. After this, I think I could ping between these two bridge
but it doesn't work!!

At First I think the problem is happen in TDMA connection, so I set IP
addresses for two TDMA nodes, and I can ping between them, so the problem
maybe in the bridge setting. But looking into the scripts, I find there is
nothing differece with bridge setting in the handbook.

Am I missing something important here?

I would greatly appreciate it if anyone could offer some information on
these questions!

Following are some of my network setting 
on the master node:

<http://freebsd.1045724.n5.nabble.com/file/n5914139/ifconfig_output_master.png> 
<http://freebsd.1045724.n5.nabble.com/file/n5914139/netstat_output_master.png> 

on the slave node:

wlan0: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0
mtu 1500
        ether 00:15:6d:6a:a6:bd
        inet6 fe80::215:6dff:fe6a:a6bd%wlan0 prefixlen 64 scopeid 0x4 
        inet 192.168.4.2 netmask 0xffffff00 broadcast 192.168.4.255 
        nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
        media: IEEE 802.11 Wireless Ethernet OFDM/24Mbps mode 11g <flag0,adhoc>
        status: running
        ssid freebsd+tdma channel 10 (2457 MHz 11g) bssid ec:88:8f:c4:40:18
        country US ecm authmode OPEN privacy OFF txpower 21 ucastrate 24
        mcastrate 24 scanvalid 60 protmode CTS wme burst tdmaslot 1
        tdmaslotcnt 2 tdmaslotlen 10000 tdmabintval 5
bridge0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu
1500
        ether 02:84:ff:8d:58:00
        inet 192.168.2.2 netmask 0xffffff00 broadcast 192.168.2.255 
        nd6 options=1<PERFORMNUD>
        id 00:00:00:00:00:00 priority 32768 hellotime 2 fwddelay 15
        maxage 20 holdcnt 6 proto rstp maxaddr 2000 timeout 1200
        root id 00:00:00:00:00:00 priority 32768 ifcost 0 port 0
        member: wlan0 flags=143<LEARNING,DISCOVER,AUTOEDGE,AUTOPTP>
                ifmaxaddr 0 port 4 priority 128 path cost 370370


Routing tables

Internet:
Destination        Gateway            Flags    Refs      Use  Netif Expire
127.0.0.1          link#3             UH          0        0    lo0
192.168.2.0/24     link#5             U           0        1 bridge
192.168.2.2        link#5             UHS         0        0    lo0
192.168.4.0/24     link#4             U           0        4  wlan0
192.168.4.2        link#4             UHS         0        0    lo0




--
View this message in context: 
http://freebsd.1045724.n5.nabble.com/fail-to-do-the-bridge-on-tdma-by-using-the-scripts-under-net80211-tp5914139.html
Sent from the freebsd-wireless mailing list archive at Nabble.com.
_______________________________________________
freebsd-wireless@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-wireless
To unsubscribe, send any mail to "freebsd-wireless-unsubscr...@freebsd.org"

Reply via email to