On 06/02/14 07:30, Thomas Mueller wrote:
I sent this message, without this top part, over an hour ago, and notice wlan0 
is still up.  I intended but forgot to CC to freebsd-current.  But I am in 
newcons, having not started X so far this boot session.  Maybe something rotten 
with Xorg, or interaction between rsu and X, or rsu and Firefox.

I am afraid to try again with X, don't want to mess the file system to the 
extent of losing data.

WLAN device is Hiro H50191 USB wireless adapter, chipset RTL8191SU.

I just updated FreeBSD-current, both amd64 and i386, now both rsu and Xorg are 
highly unstable, at least on amd64.

FreeBSD amelia4 11.0-CURRENT FreeBSD 11.0-CURRENT #6 r266948: Sun Jun  1 
19:12:44 UTC 2014     root@amelia4:/usr/obj/usr/src/sys/SANDY11NC  amd64

root@amelia4:~ # ls -l /usr/src/sys/dev/usb/wlan

total 1164

-rw-r--r--  1 root  wheel   65759 Jun  1 16:23 if_rsu.c

-rw-r--r--  1 root  wheel   19964 Jun  1 16:23 if_rsureg.h


This is a change for the worse.  Now I can connect with Hiro H50191; bug in re 
Ethernet driver persists, so I can't connect that way.

I also had several crashes in Xorg, so am typing this with vi in newcons.



Re-compile the rsu module with USB debugging enabled:

Add to: sys/modules/usb/rsu/Makefile


Rebuild and install.

After that lookup the debug knob using "sysctl hw.usb | grep rsu" and set it to 16. Then collect some debug messages in dmesg, when problems appear.

Thank you.


freebsd-wireless@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-wireless-unsubscr...@freebsd.org"

Reply via email to