https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=203827

            Bug ID: 203827
           Summary: hostapd getting stuck with net.bpf.zerocopy_enable=1
           Product: Base System
           Version: 10.0-STABLE
          Hardware: amd64
                OS: Any
            Status: New
          Severity: Affects Some People
          Priority: ---
         Component: wireless
          Assignee: freebsd-wireless@FreeBSD.org
          Reporter: nde...@gmail.com

Just upgraded to 10-stable from today and I've noticed several wireless clients
can no longer authenticate.

Running hostapd with debug in foreground shows single client authenticate then
no more log messages are displayed. Killing hostapd with Ctrl-C shows the
following message:

  ^Celoop: could not process SIGINT or SIGTERM in two seconds. Looks like there
  is a bug that ends up in a busy loop that prevents clean shutdown.
  Killing program forcefully.

Tracing hostapd shows it's getting stuck at pcap_next(), so I've made a wild
guess and tried disabling some non-default bpf related sysctls I've set, namely
net.bpf.zerocopy_enable which seems to made hostapd happy again.

I see a few bpf.c commits from Aug that might be suspect:
  r286859 | loos | 2015-08-17 19:06:14 +0000 (Mon, 17 Aug 2015) | 17 lines
  r286856 | loos | 2015-08-17 18:43:39 +0000 (Mon, 17 Aug 2015) | 29 lines
  r286850 | loos | 2015-08-17 18:21:18 +0000 (Mon, 17 Aug 2015) | 18 lines

-- 
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
freebsd-wireless@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-wireless
To unsubscribe, send any mail to "freebsd-wireless-unsubscr...@freebsd.org"

Reply via email to