Sat, 28 Nov 2015 20:06:21 +0200 було написано Steve Wills <>:


My Raspberry Pi has a urtwn USB WiFi device. It was working previously,
at r281469. It's been a while, but I updated to r291262 and now it seems
to associate, but can't get a DHCP lease. When I run tcpdump, it looks
like it's receiving but not transmitting. (But obviously it transmits
enough to associate.) Looking at recent commits, I'm building r290629
and will test that, as I suspect r290630. Any suggestions or should I
just bisect to the exact commit? I can send more detailed debugging info
if needed, just let me know what would help.

1) chip name?
2) have you tried to run 'tcpdump -y IEEE802_11_RADIO --no-promiscuous-mode'?

but not transmitting
Which device is used to monitor the traffic? If this is the same device,
then you will not know about transmission failure/success,
since tcpdump uses info from ieee80211_radiotap_tx().

Any suggestions or should I just bisect to the exact commit?
Probably, yes (it works for me without any issues on any revision).

P.S. If problem is in r290630, then you can try to replace URTWN_MACID_BC with URTWN_MACID_BSS in urtwn_tx_data() (it was hardcoded as 0 in previous revision).

_______________________________________________ mailing list
To unsubscribe, send any mail to ""

Reply via email to