Hey all!

I can't seem to get an RTL8187B-chipset USB dongle (802.11 b/g) to work
under FreeBSD 10.2-RELEASE.

The device gets somewhat recognized, since "urtw" is loaded albeit with
an error:

|urtw0: <vendor 0x0bda product 0x8187, class 0/0, rev 2.00/2.00, addr
2> on usbus3
|urtw0: could not allocate USB transfers, err=USB_ERR_NO_PIPE
|device_attach: urtw0 attach returned 6

I also tried to load it through the Windows XP drivers via ndis (rtl8187B.sys
and the respective .inf), but while the module is compiled without warnings,
kldloading it still produces the same error. I have tried kldunloading
the if_urtw.ko
module and re-kldloading the compiled one (in case there is something like
a race condition) to no avail.

As a side-note, the device is correctly recognised, a driver is loaded and
it successfully connects to wireless networks under Linux.

Any ideas?

System: i386, Architecture Version: 2
running:
|FreeBSD 10.2-RELEASE #0 r286666: Wed Aug 12 19:31:38 UTC 2015
|r...@releng1.nyi.freebsd.org:/usr/obj/usr/src/sys/GENERIC
_______________________________________________
freebsd-wireless@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-wireless
To unsubscribe, send any mail to "freebsd-wireless-unsubscr...@freebsd.org"

Reply via email to