https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=207242

            Bug ID: 207242
           Summary: urtw0: could not allocate USB transfers,
                    err=USB_ERR_NO_PIPE (FreeBSD 10.2-RELEASE)
           Product: Base System
           Version: 10.2-RELEASE
          Hardware: i386
                OS: Any
            Status: New
          Severity: Affects Some People
          Priority: ---
         Component: wireless
          Assignee: freebsd-wireless@FreeBSD.org
          Reporter: pni...@gmail.com
                CC: freebsd-i...@freebsd.org
                CC: freebsd-i...@freebsd.org

Hey all!

I can't seem to get an RTL8187B-chipset USB dongle (802.11 b/g) to work
under FreeBSD 10.2-RELEASE (i386) and the GENERIC kernel.

The device gets somewhat recognized, since "urtw" is loaded albeit with
an error:

urtw0: <vendor 0x0bda product 0x8187, class 0/0, rev 2.00/2.00, addr2> on sbus3
urtw0: could not allocate USB transfers, err=USB_ERR_NO_PIPE
device_attach: urtw0 attach returned 6

I also tried to load it through the Windows XP drivers via ndis (rtl8187B.sys
and the respective .inf), but while the module is compiled without warnings,
kldloading it still produces the same error. I have tried kldunloading
the if_urtw.ko module and re-kldloading the compiled one (in case there is
something like a race condition) to no avail.

As a side-note, the device is correctly recognised, a driver is loaded and
it successfully connects to wireless networks under OpenBSD and Linux.

-- 
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
freebsd-wireless@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-wireless
To unsubscribe, send any mail to "freebsd-wireless-unsubscr...@freebsd.org"

Reply via email to