I tried to install FreeBSD 12.0 on a new Intel NUC 8i3BEH. Unfortunately, I
didn't manage to get wifi working. It has Intel Wireless AC 9560 (see the
'iwm0@pci0' entry in the attached output of pciconf -lv).

It seems that the iwm driver supports intel wireless series 8000, but there
is no support for 9000 yet. I made some quick hacky attempts to use 8000
driver for it (using same code with newly added firmware), but that failed:
The card was recognized and firmware was loaded, but there was no
notification that it was alive (iwm_alive_fn in if_iwm.c was never called).

I am attaching the last version of my patch, which also includes a lot of
debugging enabled (without the newly added firmware) and a corresponding
dmesg output.

I tried several versions of the firmware code (various versions from linux
firmware packages and one recommended by Intel in
but none of them worked.

Unfortunately, I will need to get that machine working rather soon, so I
will probably not be able to do much more testing of FreeBSD there this
time, but I am writing here my experience in case it could be helpful.


Attachment: pciconf_-lv
Description: Binary data

Attachment: dmesg
Description: Binary data

Attachment: patch
Description: Binary data

freebsd-wireless@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-wireless-unsubscr...@freebsd.org"

Reply via email to