Hi Adrian,

Did you get a chance to look? It's in PR 136271.

I wonder if I'm missing something obvious? I've just installed 8.0
BETA1, updated to the latest sources (with csup), done a full install
with the GENERIC kernel and rebooted. Then I tried to build the XEN
kernel but get the error mentioned in the PR.

If it's working for you I guess it must be me!

Tim.

On Fri, Jul 03, 2009 at 12:23:37PM +0800, Adrian Chadd wrote:
> Just create a PR with the details and email me the number. I'll look
> at fixing it if it is broken.
> 
> It has been working for me though!
> 
> 
> 
> Adrian
> 
> 2009/7/3 Tim Bishop <t...@bishnet.net>:
> > Just FYI, here's an email I sent to freebsd-current earlier. I should
> > maybe have sent it here instead, but I forgot, so this is just a quick
> > ping in case you don't follow freebsd-current.
> >
> > Thanks,
> >
> > Tim.
> >
> > ----- Forwarded message from Tim Bishop <tim-li...@bishnet.net> -----
> >
> > Date: Thu, 2 Jul 2009 16:50:55 +0100
> > From: Tim Bishop <tim-li...@bishnet.net>
> > To: freebsd-curr...@freebsd.org
> > Subject: XEN kernel config - supposed to build?
> >
> > I'm building the XEN kernel config on a recent (today) csup of CURRENT,
> > but I'm getting the following build error:
> >
> > # make buildkernel KERNCONF=XEN
> > ...
> > cc -c -O -pipe  -std=c99 -g -Wall -Wredundant-decls -Wnested-externs 
> > -Wstrict-prototypes  -Wmissing-prototypes -Wpointer-arith -Winline 
> > -Wcast-qual  -Wundef -Wno-pointer-sign -fformat-extensions -nostdinc -I. 
> > -I/usr/src/sys -I/usr/src/sys/contrib/altq -D_KERNEL 
> > -DHAVE_KERNEL_OPTION_HEADERS -include opt_global.h -fno-common 
> > -finline-limit=8000 --param inline-unit-growth=100 --param 
> > large-function-growth=1000  -mno-align-long-strings 
> > -mpreferred-stack-boundary=2  -mno-mmx -mno-3dnow -mno-sse -mno-sse2 
> > -mno-sse3 -ffreestanding -fstack-protector -Werror 
> > /usr/src/sys/xen/evtchn/evtchn.c
> > cc1: warnings being treated as errors
> > /usr/src/sys/xen/evtchn/evtchn.c:653: warning: initialization from 
> > incompatible pointer type
> > *** Error code 1
> >
> > Is this supposed to be working? Or have I dived randomly in and missed
> > the pool? :-)
> >
> > Thanks,
> >
> > Tim.
> >
> > ----- End forwarded message -----
> >
> > --
> > Tim Bishop
> > http://www.bishnet.net/tim/
> > PGP Key: 0x5AE7D984
> > _______________________________________________
> > freebsd-xen@freebsd.org mailing list
> > http://lists.freebsd.org/mailman/listinfo/freebsd-xen
> > To unsubscribe, send any mail to "freebsd-xen-unsubscr...@freebsd.org"
> >


Tim.

-- 
Tim Bishop
http://www.bishnet.net/tim/
PGP Key: 0x5AE7D984
_______________________________________________
freebsd-xen@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-xen
To unsubscribe, send any mail to "freebsd-xen-unsubscr...@freebsd.org"

Reply via email to