I anyone able to run a amd64 FreeBSD guest in the Xen-4.0 that ships
with Debian-Squeeze? Dom0 is Debian's 2.6.32.25 Xen kernel.  Hardware
is a Phenom II.

I get a sig11 in xend.

I compiled XENHVM on FreeBSD-9.0-current as of Jan 10.  I am using
this Xen config file just to test booting the kernel:

kernel = '/home/xen/boot/freebsd-amd64-90current-2011019-kernel'
memory = '256'
name = 'freebsd'
builder = 'hvm'

(the builder= line is required, otherwise the python script doesn't
recognize the kernel as a valid kernel)

[2011-01-19 08:28:29 1313] DEBUG (XendDomainInfo:2508) 
XendDomainInfo.constructDomain
[2011-01-19 08:28:29 1313] DEBUG (balloon:220) Balloon: 1706900 KiB free; need 
16384; done.
[2011-01-19 08:28:29 1313] DEBUG (XendDomain:464) Adding Domain: 1
[2011-01-19 08:28:29 1313] DEBUG (XendDomainInfo:2818) 
XendDomainInfo.initDomain: 1 256
[2011-01-19 08:28:30 1313] DEBUG (image:891) args: boot, val: c
[2011-01-19 08:28:30 1313] DEBUG (image:891) args: fda, val: None
[2011-01-19 08:28:30 1313] DEBUG (image:891) args: fdb, val: None
[2011-01-19 08:28:30 1313] DEBUG (image:891) args: soundhw, val: None
[2011-01-19 08:28:30 1313] DEBUG (image:891) args: localtime, val: 0
[2011-01-19 08:28:30 1313] DEBUG (image:891) args: serial, val: None
[2011-01-19 08:28:30 1313] DEBUG (image:891) args: std-vga, val: 0
[2011-01-19 08:28:30 1313] DEBUG (image:891) args: isa, val: 0
[2011-01-19 08:28:30 1313] DEBUG (image:891) args: acpi, val: 1
[2011-01-19 08:28:30 1313] DEBUG (image:891) args: usb, val: 0
[2011-01-19 08:28:30 1313] DEBUG (image:891) args: usbdevice, val: None
[2011-01-19 08:28:30 1313] DEBUG (image:891) args: gfx_passthru, val: None
[2011-01-19 08:28:30 1313] INFO (image:822) Need to create platform 
device.[domid:1]
[2011-01-19 08:28:30 1313] DEBUG (XendDomainInfo:2845) 
_initDomain:shadow_memory=0x0, memory_static_max=0x10000000, 
memory_static_min=0x0.
[2011-01-19 08:28:30 1313] INFO (image:182) buildDomain os=hvm dom=1 vcpus=1
[2011-01-19 08:28:30 1313] DEBUG (image:949) domid          = 1
[2011-01-19 08:28:30 1313] DEBUG (image:950) image          = 
/home/xen/boot/freebsd-amd64-90current-2011019-kernel
[2011-01-19 08:28:30 1313] DEBUG (image:951) store_evtchn   = 2
[2011-01-19 08:28:30 1313] DEBUG (image:952) memsize        = 256
[2011-01-19 08:28:30 1313] DEBUG (image:953) target         = 256
[2011-01-19 08:28:30 1313] DEBUG (image:954) vcpus          = 1
[2011-01-19 08:28:30 1313] DEBUG (image:955) vcpu_avail     = 1
[2011-01-19 08:28:30 1313] DEBUG (image:956) acpi           = 1
[2011-01-19 08:28:30 1313] DEBUG (image:957) apic           = 1
[2011-01-19 08:28:31 1312] CRITICAL (SrvDaemon:232) Xend died due to signal 11! 
 Restarting it.
_______________________________________________
freebsd-xen@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-xen
To unsubscribe, send any mail to "freebsd-xen-unsubscr...@freebsd.org"

Reply via email to