I am running a diskless boot amd64 hvm.  I just updated to a
10-current from December 28, 2011

I now get this when the kernel (which boots OK) wants to mount the NFS

panic: Unregistered use of FPU in kernel
cpuid = 0

I should mention:
- the PXE as built into qemu didn't work for me (some parameter
  passing went wrong with our pxe /boot files) so I use ipxe.  This
  worked with the older FreeBSD-current I had until this update.
- kernel config is straight amd64/conf/XENHVM

Is there some way to trap this and debug it, while the thing is
running in a hvm->qemu startup in a VNC session?

The FreeBSD that was working seems to have been current as of Jan 11,
2011 (how fast a year slips...).  I can't boot through to that one now
since unrelated activity destroyed that installation's /usr, although
I can still get it in single user.  I made no other changes(tm) from
the working state than updating FreeBSD.

Here is the Xen config:

kernel = '/usr/lib/xen-4.0/boot/hvmloader'
device_model = '/usr/lib/xen-4.0/bin/qemu-dm'
memory = '256'
name = 'fbhvm'
builder = 'hvm'

boot = 'd'
disk = [

vif = ['type=ioemu,mac=00:16:3e:01:a0:04,bridge=craxenbridge']

on_crash  = 'preserve'
on_poweroff = 'preserve'

vcpus = 1

vfb = [ 'type=vnc,vncdisplay=4,vncunused=1' ]

vnc = 1
vnclist = ''

Martin Cracauer <craca...@cons.org>   http://www.cons.org/cracauer/
freebsd-xen@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-xen-unsubscr...@freebsd.org"

Reply via email to