On 31/03/13 19:45, Cherry G.Mathew wrote:
> 
> On 21/02/13 10:18, tech mailinglists wrote:
>> Hello all,
>>
>> I have created a FreeBSD PV DomU image formatted with ZFS. I compiled
>> FreeBSD with KERNCONF=XEN for the kernel and the normal world and
>> distribution target. Then I transfered it to a Debian Dom0 with Xen 4.2.1.
>>
>> I tried to boot the image befor I migrate it to LVM and I now get teh
>> following output:
>>
> 
> [...]
> 
>> run_interrupt_driven_hooks: still waiting after 300 seconds for
>> xenbus_free_evtchn
>> panic: run_interrupt_driven_config_hooks: waited too long
>> cpuid = 0
>> KDB: enter: panic
>> [ thread pid 0 tid 100000 ]
>> Stopped at      kdb_enter+0x3a: movl    $0,kdb_why
>> db>
> 
> 
> Try see if patch below should help the boot a bit along.

The problem is already solved, it was crashing because blkback in Dom0
was not correctly working -- nothing to do with FreeBSD. The 9.x
releases work correctly, the problem is with HEAD and the backtrace I've
posted. BTW, if you wish to try HEAD you will need the ELFNOTE patch
I've posted and boot with "hw.mca.enabled=0" to get to the panic I've
posted earlier.

_______________________________________________
freebsd-xen@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-xen
To unsubscribe, send any mail to "freebsd-xen-unsubscr...@freebsd.org"

Reply via email to