El 09/10/14 a les 16.08, Jay West ha escrit:
> We're running lots of FreeBSD10 VM's  under Xenserver 6.2, and using FreeNas
> 9.X for iscsi storage. Note, none of the VM's see iSCSI - just the
> hypervisors see it to create their storage repositories.
> 
>  
> 
> We've noticed an ongoing issue with recovery from crashes or issues with the
> NAS. This doesn't happen often at all, but the nas will reboot about once a
> year.
> 
>  
> 
> Windows VM's seem to recover fine. FreeBSD, not so much. The pattern seems
> to be that if the NAS holding the SR's for the hypervisor reboots, when the
> freebsd vm's come up that have just one virtual disk (boot), it complains
> about unclean shutdown and fsck needs to be run. No problem, running fsck
> fixes it. However, if the freebsd vm has two virtual disks (boot and data),
> the first one (say, ada0) complains about unclean shutdown and fsck will fix
> it. But the second disk (say, ada1) is not found. All we get is "can't stat
> /dev/ada1p1" or somesuch, and /dev/ad1 is missing from /dev.
> 
>  
> 
> This seems to be a pretty consistent failure mode. We've tried to detach the
> data disk and attach it to a different VM - but no joy.

When this happens, can you log into the affected VM (with the disk
"supposedly" attached) and paste the output of `xenstore-ls -fp
/local/domain/<domid>` (replace <domid> with the ID of the domain) here.
You will need the xen-tools package installed in order to do that.

It looks to me like this is some kind of issue with the XenServer
storage manager, so I would suggest asking this on the XenServer mailing
lists (xs-de...@lists.xenserver.org)

Roger.

_______________________________________________
freebsd-xen@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-xen
To unsubscribe, send any mail to "freebsd-xen-unsubscr...@freebsd.org"

Reply via email to