Roger Pau Monné wrote on 05/13/15 11:51:

El 13/05/15 a les 10.46, Ruslan Makhmatkhanov ha escrit:
Yes, the system is now booted successfully! But `xl list` doesn't work

root@:~ # xl list
libxl: error: libxl.c:669:libxl_list_domain: getting domain info list:
Cannot allocate memory
libxl_list_domain failed.
Shell memory values are unlimited too:

root@:~ # ulimit -a
cpu time               (seconds, -t)  unlimited
file size           (512-blocks, -f)  unlimited
data seg size           (kbytes, -d)  33554432
stack size              (kbytes, -s)  524288
core file size      (512-blocks, -c)  unlimited
max memory size         (kbytes, -m)  unlimited
locked memory           (kbytes, -l)  64

Shell memory is not unlimited, as the output above shows. `ulimit -l
unlimited` should fix that.


My bad. `ulimit -l unlimited` doesn't worked for me, but changing the limit via /etc/login.conf did. Now it works flawlessly. Thank you! Is there any resource where these cases covered ("Cannot allocate memory" and disabling IOMMU because of erratas)? Just want to know bloody details.

And one more question, am I right that PV-guests are no more supported in FreeBSD? We tried to run Debian guest in PV mode like described here:

but guest's kernel panicking like that:

Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

Full log:
Or it's some bad zfs setup on dom0 system?

This is FreeBSD HVM attempt:
libxl: error: libxl_dm.c:1482:device_model_spawn_outcome: domain 5 device model: spawn failed (rc=-3) libxl: error: libxl_create.c:1319:domcreate_devmodel_started: device model did not start: -3
libxl: error: libxl_dm.c:1586:kill_device_model: Device Model already exited

Full log:


T.O.S. Of Reality
_______________________________________________ mailing list
To unsubscribe, send any mail to ""

Reply via email to