El 05/11/15 a les 15.09, Thomas Laus ha escrit:
>> So the VNC client attaches successfully to the server, but the output is
>> just a black screen? IMHO, that looks more like a guest or VNC issue
>> rather than a Xen/Qemu one. Have you tried different guest OSes and
>> different VNC clients? (TigerVNC Viewer has always worked fine for me).
>> But regarding your question: no, Xen Dom0 doesn't require X at all in
>> order to run.
> I tried other guest OS's and VNC clients with the same result and came to the 
> conclusion that all of my guest OS's were not booting.  All of my VNC clients 
> displayed the name of the guest OS in the margin, but had a black screen.  I 
> looked at the 'xl list' billboard and the guest OS did not have a 'r' in the 
> column.  The startup log for all of the guests had this line:
> 'xen be core: can't open gnttab device'

Is there anything else in the Qemu logs?

Also, can you post the output of `xl -vvv create <guest_cfg>` and `xl
list` while the domain is running?

> My guess is that the 'gnttab' device is critical to a guest startup.  I could 
> not find any reference to this item.  What am I missing?

No, gnttab is not critical, Qemu should work without it.


freebsd-xen@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-xen-unsubscr...@freebsd.org"

Reply via email to