El 23/2/16 a les 10:22, Gustau Pérez ha escrit:
> 
> 
> El 22/02/16 a les 17:18, Roger Pau Monné ha escrit:
>>
>> AFAICT this is a gp that's injected by Xen when Dom0 tries to execute
>> certain instructions that Xen cannot emulate (INS or OUTS). I've fixed
>> this sometime ago in Xen upstream, but I seem to have missed to add the
>> relevant patches to the port. Can you try to apply the following patches:
>>
>> https://people.freebsd.org/~royger/xen_ins/
>>
>> To the xen-kernel port and rebuild it? There's no need to apply them to
>> the xen-tools port, this only affects the hypervisor but not the toolstack.
>    Hi Roger,
> 
>    I've able to apply those patches to the xen-kernel port and they
> fixed the panic. Do you want me to send you the port diff o submit a PR?
> If you submit those yourself, please mind to add them to the
> EXTRA_PATCHES knob in the port Makefile (I happened to me the first time
> and that leaded me to think your patches did not fix the problem).

I need to update the port anyway (will try to do it tomorrow), so I can
also add the patches while there.

>    Regarding the hotplug stuff, I reworked the patches to the kernel (it
> applied but with displacements) and two of the xen-tools ones. Do you
> want me to post them somewhere?

Yes please, although I'm not sure when I will have time to work on those.

Roger.

_______________________________________________
freebsd-xen@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-xen
To unsubscribe, send any mail to "freebsd-xen-unsubscr...@freebsd.org"

Reply via email to