On Fri, 11 Mar 2016, skar...@gmail.com wrote:

Hello,

> Hello all,
> 
> I have tried to run FreeBSD 11 rev.296614 and /usr/ports/emulator/xen on
> two different hardware configurations and the result was the same. XEN
> kernel loads successfully but it hangs and restart on dom0 Init  with
> *"Error* creating domain 0" and "ELF boundaries" error.
> 
> I tried on :
>  *) Dell Vostro with CPU i7-2640M
>  *) SuperMicro X10DRW-N with CPU E5-2667 v3
> 
> Both CPU are listed to support VT-d and VT-x. On both machines I have EPT
> and DMAR available.
> On both machines virtualization is enabled in BIOS.
> 
> How can I proceed to catch the error source hardware related, XEN related
> or FreeBSD related ?

This has also been reported in the freebsd-virt mailing list:

https://lists.freebsd.org/pipermail/freebsd-virtualization/2016-March/004257.html

It seems like something is broken while linking the kernel, so the 
resulting ELF program headers physical address is wrong. AFAICT using 
r295683 or older revisions should work fine. As said in the other email, 
I'm currently bisecting the kernel in order to try to find the cause of 
the issue.

Roger.
_______________________________________________
freebsd-xen@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-xen
To unsubscribe, send any mail to "freebsd-xen-unsubscr...@freebsd.org"

Reply via email to