Hello,

On Tue, May 10, 2016 at 05:00:02PM +0100, Miguel C wrote:
> See this PR from 2014 -->
> https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=188369
> 
> (there another earlier about the same error message on 9.X and that was
> fixed on 10-CURRENT at the time, but was "broke" later)
> 
> The issue happen with any NetBSD version from 5.x to 7.x with any xen
> version but it only stared in FreeBSD 10-Current, so I was always inclined
> to this being a regression in 10 not a NetBSD backend issue. Also I did
> post in netbsd mailling list and the reply was something in the lines of
> "was working fine, nothing changed at our side, so its probably FreeBSD
> problem"
> 
> Also as I posted in that PR I experienced a similar issue with Windows
> GPLPV drivers and the dev fixed it, the issue was that certain features
> were not supported and the frontend just assume they were cause that's how
> it works on linux, and I'm no expert so I can go into much detail, but it
> was related to checksum, tso and I think gso.
> 
> I tried to bisect the git commits, but there was simply to much changes,
> what I did find was that this never worked on 10.x +++ only 9, anyway
> everything was reported there and eventually I got no replies back so I
> gave up on NetBSD+FreeBSD-10.
> 
> Unfortunately this needs someone with proper skills on either side
> (netbsd/freeBSD) to be fixed, the perfect solution would be to add NetBSD
> backend support for this things (just not sure if its worth the time for
> the possible performance gain!? - also that's a question for the NetBSD
> folks ofc)

I think I have found what's causing the issue, but I don't have a NetBSD 
Dom0 in order to test the fix, could some of you please test the following 
patch and report back:

https://people.freebsd.org/~royger/0001-xen-netfront-fix-feature-detection.patch

It should apply cleanly against FreeBSD HEAD.

Thanks, Roger.
_______________________________________________
freebsd-xen@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-xen
To unsubscribe, send any mail to "freebsd-xen-unsubscr...@freebsd.org"

Reply via email to