On Fri, Jan 20, 2017 at 07:20:15PM +0300, Andrey V. Elsukov wrote:
> On 20.01.2017 18:57, Trond Endrestøl wrote:
> > > Here is the situation:
> > > I have a VPS server from a well reputed provider (and they deserve the
> > > reputation), running FreeBSD 11 stable x64 under Xen Full Virtualization
> > > (HVM). I have the xn0 interface which is working fine. I intend to use 
> > > VIMAGE,
> > > so I compiled the kernel, added cloned_interface="bridge0" and restarted 
> > > the
> > > server. But as soon as I am attaching the xn0 to bridge0, the kernel is
> > > panicking and the server restarting.
> > > Any suggestion/pointer/test-instruction is highly appreciated.
> > 
> > The code crashes at line 427 of sys/netinet/if_ether.c:
> > 
> >   ARPSTAT_INC(txrequests);
> > 
> > See
> > https://svnweb.freebsd.org/base/stable/11/sys/netinet/if_ether.c?view=annotate#l427
> > 
> > stable/11 has problems accounting the outgoing octets of any xn
> > interface, although this isn't connected to your case.
> > 
> > Just to rule out any uncertainty, try this patch:
> > 
> > https://svnweb.freebsd.org/base?view=revision&revision=308126
> > 
> > See PR 213439,
> > https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=213439
> > 
> > Note, I'm not a developer nor a committer, just a humble sysadmin.
> 
> This problem is unrelated. ARP statistics is global and isn't related to
> some specific interface. IMHO, the kernel panics due to missing VNET
> context. As I see from the code in sys/dev/xen, it is not capable with
> VIMAGE.

I cannot really look into this right now due to lack of time, but I'm more than
happy to review/apply patches in order to fix this.

Roger.
_______________________________________________
freebsd-xen@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-xen
To unsubscribe, send any mail to "freebsd-xen-unsubscr...@freebsd.org"

Reply via email to