2011/12/22 Germán Marcos <gemar...@gmail.com>:
> 2011/12/22 Olivier Duchateau <duchateau.oliv...@gmail.com>:
>> It seems textproc/p5-XML-Parser is missing
>
> But I have p5-XML-Parser-2.41 !!
>
> Last anotation in /usr/ports/UPDATING (20111219) is about perl5.14.  I
> have done the update and I have used "perl-after-upgrade".  If the
> update of xfce4-utils have been made between update perl and the
> script "perl-after-upgrade", could it be the problem?  Honestly, I do
> not remember the order.
>

I don't know every commands about Perl. But update of xfce4-utils
stands out on 28th October. Furthermore this module is not essential.

Perhaps committers (@crees, @rene) on this list known this issue.

> Do you think is a good idea to try:
>
> cd /usr/ports/sysutils/xfce4-utils
> make deinstall clean
> make install clean
>

You can, or you can try to alter Makefile, as suggest in log.

Add in CONFIGURE_ARGS macro like this

CONFIGURE_ARGS+=--with-xsession-prefix=${PREFIX} \
       --with-vendor-info=FreeBSD \
       --disable-xfconf-migration

And in pkg-plist file change this line (12)
lib/xfce4/xfconf-migration/xfconf-migration-4.6.pl
by
@comment lib/xfce4/xfconf-migration/xfconf-migration-4.6.pl

This Perl script helps in migration of Xfce 4.6.x to Xfce 4.8.

>>
>> - taken from 'config.log'
>> [...]
>> configure:13879: checking for perl5
>> configure:13897: found /usr/bin/perl5
>> configure:13909: result: /usr/bin/perl5
>> configure:13923: checking for XML::Parser
>> configure:13929: result: not found
>> configure:13931: error: perl module XML::Parser not found; required for 
>> Xfconf m
>> igration. Pass --disable-xfconf-migration to ignore this.
>> [...]
>>
>>
>> - taken from 'xfce4-utils.txt'
>> [...]
>> checking for perl5.8... no^M
>> checking for perl5.6... no^M
>> checking for perl5... /usr/bin/perl5^M
>> checking for XML::Parser... not found^M
>> configure: error: perl module XML::Parser not found; required for Xfconf 
>> migrati
>> on. Pass --disable-xfconf-migration to ignore this.
>> [...]
>>
>> 2011/12/22 Germán Marcos <gemar...@gmail.com>:
>>> Ok,
>>>
>>> these are the files:
>>>
>>> http://dl.dropbox.com/u/54287047/config.log
>>>
>>> http://dl.dropbox.com/u/54287047/xfce4-utils.txt
>>>
>>>
>>> Thank you
>>>
>>> Germán Marcos.
>>>
>>>
>>>
>>> 2011/12/22 Olivier Duchateau <duchateau.oliv...@gmail.com>:
>>>> Could you host somewhere your log, or send Problem Report, because
>>>> this mailling list don't accept attachment.
>>>>
>>>> 2011/12/22 Germán Marcos <gemar...@gmail.com>:
>>>>> Dear maintainer,
>>>>>
>>>>> First of all, many thanks for your work in FreeBSD and XFCE.
>>>>>
>>>>> I have found an error compiling the last xfce4-utils-4.8.3_2.
>>>>>
>>>>> I think that I am sending you all the information:
>>>>> xfce4-utils.txt is the script of the session with pkg_info, uname -a
>>>>> and portmaster
>>>>> config.log is the the file you asked for
>>>>>
>>>>> I hope that this will be useful.
>>>>>
>>>>> Best regards
>>>>>
>>>>> Germán Marcos.
>>>>>
>>>>> _______________________________________________
>>>>> freebsd-xfce@freebsd.org mailing list
>>>>> http://lists.freebsd.org/mailman/listinfo/freebsd-xfce
>>>>> To unsubscribe, send any mail to "freebsd-xfce-unsubscr...@freebsd.org"
>>>>>
>>>>
>>>>
>>>>
>>>> --
>>>> olivier
>>
>>
>>
>> --
>> olivier



-- 
olivier
_______________________________________________
freebsd-xfce@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-xfce
To unsubscribe, send any mail to "freebsd-xfce-unsubscr...@freebsd.org"

Reply via email to