Do you try to recompile Xorg without HAL support (Xfce core elements
don't need it).

For shutdown (and reboot), Xfce needs to configure polkit. You must
create .pkla file in
/usr/local/etc/polkit-1/localauthority/50-local.d/ (see
x11-wm/xfce4-session/files/pkg-message.in).

For shutdown and reboot action you can run `pkaction | grep consolekit.system'

2012/10/3 J B <jb.1234a...@gmail.com>:
> I have done some additional testing.
> 1. I recompiled all installed XFCE ports.
> 2. I nuked
> ~/.config/xfce*
> ~/.cache/sessions/
> 3. Then I tested as below:
>
> a) $ startx
>     I did not do anything, just Log Out from XFCE (orginal
> /unconfigured desktop).
>     $ cat .startx.log
> xauth:  file /home/jb/.serverauth.1817 does not exist
>
> X.Org X Server 1.7.7
> Release Date: 2010-05-04
> X Protocol Version 11, Revision 0
> Build Operating System: FreeBSD 9.1-RC1 i386
> Current Operating System: FreeBSD localhost.localdomain 9.1-RC1
> FreeBSD 9.1-RC1 #0: Tue Aug 14 03:56:40 UTC 2012
> r...@obrian.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC i386
> Build Date: 02 September 2012  11:52:43AM
>
> Current version of pixman: 0.24.2
>         Before reporting problems, check http://wiki.x.org
>         to make sure that you have the latest version.
> Markers: (--) probed, (**) from config file, (==) default setting,
>         (++) from command line, (!!) notice, (II) informational,
>         (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
> (==) Log file: "/var/log/Xorg.0.log", Time: Wed Oct  3 21:15:49 2012
> (==) Using config file: "/usr/local/etc/X11/xorg.conf"
> (EE) config/hal: NewInputDeviceRequest failed (8)
> (EE) config/hal: NewInputDeviceRequest failed (8)
> /usr/local/bin/startxfce4: X server already running on display :0
> xrdb:  "Xft.hinting" on line 31 overrides entry on line 6
> xrdb:  "Xft.hintstyle" on line 32 overrides entry on line 7
>
> (xfsettingsd:1875): GLib-CRITICAL **: g_str_has_prefix: assertion
> `prefix != NULL' failed
>
> (xfwm4:1863): GLib-CRITICAL **: g_str_has_prefix: assertion `prefix !=
> NULL' failed
>
> (xfwm4:1863): xfwm4-WARNING **: The property
> '/general/double_click_distance' of type int is not supported
>
> (xfdesktop:1871): GLib-GIO-CRITICAL **: g_file_get_path: assertion
> `G_IS_FILE (file)' failed
>
> (xfdesktop:1871): GLib-GIO-CRITICAL **: g_file_get_path: assertion
> `G_IS_FILE (file)' failed
>
> (xfdesktop:1871): GLib-GIO-CRITICAL **: g_file_get_path: assertion
> `G_IS_FILE (file)' failed
>
> (xfdesktop:1871): GLib-GIO-CRITICAL **: g_file_get_path: assertion
> `G_IS_FILE (file)' failed
>
> (xfdesktop:1871): GLib-GIO-CRITICAL **: g_file_get_path: assertion
> `G_IS_FILE (file)' failed
> xinit: connection to X server lost
>
> waiting for X server to shut down
> $
>
> b) $ startx
>     This time I configured the desktop (Menu - Settings):
>     - just changed some font sizes
>     - removed bottom panel, moved upper panel to bottom
>     - I did NOT touch Session and Startup (this is where xfsettingsd resides)
>     Then I just did Log Out from XFCE (configured desktop).
>     $ cat .startx.log
> xauth:  file /home/jb/.serverauth.1907 does not exist
>
> X.Org X Server 1.7.7
> Release Date: 2010-05-04
> X Protocol Version 11, Revision 0
> Build Operating System: FreeBSD 9.1-RC1 i386
> Current Operating System: FreeBSD localhost.localdomain 9.1-RC1
> FreeBSD 9.1-RC1 #0: Tue Aug 14 03:56:40 UTC 2012
> r...@obrian.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC i386
> Build Date: 02 September 2012  11:52:43AM
>
> Current version of pixman: 0.24.2
>         Before reporting problems, check http://wiki.x.org
>         to make sure that you have the latest version.
> Markers: (--) probed, (**) from config file, (==) default setting,
>         (++) from command line, (!!) notice, (II) informational,
>         (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
> (==) Log file: "/var/log/Xorg.0.log", Time: Wed Oct  3 21:19:46 2012
> (==) Using config file: "/usr/local/etc/X11/xorg.conf"
> (EE) config/hal: NewInputDeviceRequest failed (8)
> (EE) config/hal: NewInputDeviceRequest failed (8)
> /usr/local/bin/startxfce4: X server already running on display :0
> xrdb:  "Xft.hinting" on line 31 overrides entry on line 6
> xrdb:  "Xft.hintstyle" on line 32 overrides entry on line 7
>
> (xfdesktop:1960): GLib-GIO-CRITICAL **: g_file_get_path: assertion
> `G_IS_FILE (file)' failed
>
> (xfdesktop:1960): GLib-GIO-CRITICAL **: g_file_get_path: assertion
> `G_IS_FILE (file)' failed
>
> (xfdesktop:1960): GLib-GIO-CRITICAL **: g_file_get_path: assertion
> `G_IS_FILE (file)' failed
>
> (xfdesktop:1960): GLib-GIO-CRITICAL **: g_file_get_path: assertion
> `G_IS_FILE (file)' failed
>
> (xfdesktop:1960): GLib-GIO-CRITICAL **: g_file_get_path: assertion
> `G_IS_FILE (file)' failed
> xinit: connection to X server lost
>
> waiting for X server to shut down
> $
> NOTE: no xfsettingsd error messages yet !
>
> c). $ startx
>     I did not do anything, just Log Out from XFCE.
>     $ cat .startx.log
>
> X.Org X Server 1.7.7
> Release Date: 2010-05-04
> X Protocol Version 11, Revision 0
> Build Operating System: FreeBSD 9.1-RC1 i386
> Current Operating System: FreeBSD localhost.localdomain 9.1-RC1
> FreeBSD 9.1-RC1 #0: Tue Aug 14 03:56:40 UTC 2012
> r...@obrian.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC i386
> Build Date: 02 September 2012  11:52:43AM
>
> Current version of pixman: 0.24.2
>         Before reporting problems, check http://wiki.x.org
>         to make sure that you have the latest version.
> Markers: (--) probed, (**) from config file, (==) default setting,
>         (++) from command line, (!!) notice, (II) informational,
>         (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
> (==) Log file: "/var/log/Xorg.0.log", Time: Wed Oct  3 21:33:19 2012
> (==) Using config file: "/usr/local/etc/X11/xorg.conf"
> (EE) config/hal: NewInputDeviceRequest failed (8)
> (EE) config/hal: NewInputDeviceRequest failed (8)
> /usr/local/bin/startxfce4: X server already running on display :0
> xrdb:  "Xft.hinting" on line 31 overrides entry on line 6
> xrdb:  "Xft.hintstyle" on line 32 overrides entry on line 7
> xinit: connection to X server lost
>
> waiting for X server to shut down xfsettingsd: Fatal IO error 0 (No
> error: 0) on X server :0.0.
> $
>
> NOTE: lack of this message I can not explain:
> xauth:  file /home/jb/.serverauth.1907 does not exist
>
> NOTE:
> -  these messages are not present any more
> (xfdesktop:1960): GLib-GIO-CRITICAL **: g_file_get_path: assertion
> `G_IS_FILE (file)' failed
> - xfsettingsd error messages appeared for the first time
>
> After that the .startx.log will look like the last one shown here,
> except there will be a random
> occurance of two different xfsettingsd error messages (sometimes none).
>
> Do you see anything valuable here for debugging ?



-- 
olivier
_______________________________________________
freebsd-xfce@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-xfce
To unsubscribe, send any mail to "freebsd-xfce-unsubscr...@freebsd.org"

Reply via email to