On 05/02/15 18:48, Will Brokenbourgh wrote:
On 05/02/15 18:05, Will Brokenbourgh wrote:
Greetings maintainers!  Thank you for all of your hard work! :-)

I am using the binary package of Thunar on FreeBSD 10.1 amd64. It has now crashed several times since my clean system install yesterday, and almost every crash the error message is:

GLib (gthread-posix.c): Unexpected error from C library during 'pthread_mutex_lock': Invalid argument. Aborting.

The crashes seem to happen during moderate disk usage, but there is no definite pattern and trying to intentionally crash it repeatedly is difficult.

First notable crash was when I had selected several files with Thunar in ~/.local/share/applications using Ctrl+left click, then right-clicked one of the selected items and chose 'Delete'. In the middle of the delete operation, Thunar crashed with the above message.

Another notable crash: Thunar was opened to a folder in my home folder, sitting unused and idle, minimized/iconified. I opened xterm (from lxpanel, NOT Thunar), then performed 'sudo pkg install smplayer'. Thunar crashed with the above message at the latter part of the package installation. I have noticed a few times in the past that some apps will crash while sitting idle when I am performing operations with pkg in xterm.

I have also tried building Thunar from the ports tree with WITH_DEBUG, but when I opened the core dump with gdb, the backtrace only provided useless numeric addresses, no function names or files.

uname -a:
FreeBSD will-freebsd 10.1-RELEASE-p9 FreeBSD 10.1-RELEASE-p9 #0: Tue Apr 7 01:09:46 UTC 2015 r...@amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC amd64

dmesg at time of crash:
pid 941 (thunar), uid 1001: exited on signal 6 (core dumped)

Other apps running:
    openbox, lxpanel, thunderbird, firefox and xterm

Hardware info:
* AMD 6-core processor (dmesg: "AMD FX(tm)-6300 Six-Core Processor (3511.78-MHz K8-class CPU)")
    * Asus M5A97 LE R2.0 motherboard
    * Radeon HD 5450 video card
    * 8 GB RAM
    * 500 GB 7,200 RPM Samsung hdd (dmesg: "SAMSUNG HD502HJ 1AJ10001")

On Ubuntu and other Linux distros, Thunar is very stable and hasn't crashed like this on the same hardware.

Please let me know if I need to provide additional information.

Thank you and God bless! :-)

Will Brokenbourgh

Hello again, maintainers,

I was finally able to get Thunar built with debug symbols and started it under gdb. In Thunar, I navigated to a folder in my home directory, double-clicked a sound file to play it, then minimized Thunar. I then performed the following commands repeatedly and Thunar crashed while sitting unused/idle:

    sudo pkg remove -y smplayer && \
    sudo pkg autoremove -y && \
    sudo pkg clean -ay && \
    sudo pkg install -y smplayer && \
    sudo ldconfig

The gdb output and backtrace are below:
- - - - -
will@will-freebsd:~ % gdb thunar
GNU gdb 6.1.1 [FreeBSD]
Copyright 2004 Free Software Foundation, Inc.
This GDB was configured as "amd64-marcel-freebsd"...
(gdb) r
Starting program: /usr/local/bin/thunar
[New LWP 101083]
[New Thread 80a006400 (LWP 101083/thunar)]
[New Thread 80a301000 (LWP 101096/thunar)]
This is SMPlayer v. 14.9.0 running on Other OS
GLib (gthread-posix.c): Unexpected error from C library during 'pthread_mutex_lock': Invalid argument. Aborting.
[New Thread 80a010000 (LWP 101094/thunar)]

Program received signal SIGABRT, Aborted.
[Switching to Thread 80a010000 (LWP 101094/thunar)]
0x0000000803e0c6ca in thr_kill () from /lib/libc.so.7
(gdb) bt
#0  0x0000000803e0c6ca in thr_kill () from /lib/libc.so.7
#1  0x0000000803ee1149 in abort () from /lib/libc.so.7
#2 0x0000000803920c55 in g_mutex_lock () from /usr/local/lib/libglib-2.0.so.0 #3 0x0000000803920c1e in g_mutex_lock () from /usr/local/lib/libglib-2.0.so.0 #4 0x00000008030eaebb in g_file_monitor_emit_event () from /usr/local/lib/libgio-2.0.so.0 #5 0x00000008038dbfb8 in g_main_context_dispatch () from /usr/local/lib/libglib-2.0.so.0 #6 0x00000008038dc34e in g_main_context_pending () from /usr/local/lib/libglib-2.0.so.0 #7 0x00000008038dc3d4 in g_main_context_iteration () from /usr/local/lib/libglib-2.0.so.0 #8 0x00000008038ddbb6 in g_main_context_invoke_full () from /usr/local/lib/libglib-2.0.so.0 #9 0x000000080390202a in g_thread_unref () from /usr/local/lib/libglib-2.0.so.0
#10 0x0000000802c524f5 in pthread_create () from /lib/libthr.so.3
#11 0x0000000000000000 in ?? ()
- - - - -

If I can provide any other information, please let me know.

Thank you! :-)

Will Brokenbourgh

Hello again maintainers,

On closer inspection, this appears to be a problem with devel/glib20, and not Thunar, as I am now seeing Firefox and Thunderbird crashing with the same error message.

I have submitted a problem report on the bug tracker for glib:

Thank you, :-)

Will Brokenbourgh

freebsd-xfce@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-xfce-unsubscr...@freebsd.org"

Reply via email to