Verifiquei e alterei todas conf´s, mas continua recebendo o mesmo ip
para os dois.
Mas o problema é que não pinga outras estações pelo endereço IP, nem
mesmo o DNS(192.168.250.200). Pinga apenas o servidor,
192.168.250.252.

Adaptador PPP VPN:
Sufixo DNS expedifico da conexão:
Endereço IP: 192.168.250.211
Mascara de sub-rede: 255.255.255.255
Gateway Padrão: 192.168.250.211

Abaixo segue os arquivos e suas confs:

guaxinim# more pptpd.conf
---------------------------------------
option /etc/ppp/ppp.conf
# turn debugging on only if you need it
##debug
# if you have multiple addresses and only want to "listen" on one:
##listen 208.212.80.82
localip 192.168.250.252
remoteip 192.168.250.210-215
pidfile /var/run/pptpd.pid


guaxinim# more ppp.conf
------------------------------------
loop:
 set timeout 0
 set log phase chat connect lcp ipcp command
 set device localhost:pptp
 set dial
 set login
 # Server (local) IP address, Range for Clients, and Netmask
 set ifaddr 192.168.250.252 192.168.250.210-192.168.250.215 255.255.255.255
 set server /tmp/loop "" 0177

loop-in:
 set timeout 0
 set log phase lcp ipcp command
 allow mode direct

pptp:
 load loop
 enable chap
 enable mschap
 enable MSChapV2
 enable proxy
 enable mppe
 enable mssfixup
 accept dns
 set dns 192.168.250.200
 set nbns 192.168.250.200
 set device !/etc/ppp/secure
 set timeout disable
 set timeout disable
 disable deflate pred1
 disable ipv6cp
 deny deflate pred1


guaxinim# more options.pptpd
--------------------------------------------
lock
debug
mtu 1490
mru 1490
proxyarp
mppe-128
debug
name *
ms-dns 192.168.250.200
ms-dns 192.168.251.1
ms-wins 192.168.250.200


-- 
Atenciosamente,
R. Filippus


On Thu, 3 Feb 2005 14:30:34 -0200, Frederick F.
<[EMAIL PROTECTED]> wrote:
> Bom, acho que tem algo errado com seu setup.. olha o meu:
> 
> cat /etc/ppp/ppp.conf
> ----------------------------------------------
> loop:
> set timeout 0
> set log phase chat connect lcp ipcp command
> set device localhost:pptp
> 
> set dial
> set login
> # Server (local) IP address, Range for Clients, and Netmask
> set ifaddr 172.16.1.200 172.16.1.201-250 255.255.255.255
> set server /tmp/loop "" 0177
> 
> loop-in:
> set timeout 0
> set log phase lcp ipcp command
> allow mode direct
> 
> pptp:
> load loop
> enable chap
> enable pap
> # Authenticate against /etc/passwd
> ##enable passwdauth
> enable proxy
> accept dns
> # DNS Servers to assign client
> set dns 172.16.1.3
> # NetBIOS/WINS Servers to assign client
> set nbns 172.16.1.3
> set device !/etc/ppp/secure
> enable MSChapV2
> enable mppe
> disable deflate pred1
> deny deflate pred1
> set timeout disable
> 
> [EMAIL PROTECTED]: cat /usr/local/etc/pptpd.conf
> ----------------------------------------------
> option /etc/ppp/ppp.conf
> # turn debugging on only if you need it
> ##debug
> # if you have multiple addresses and only want to "listen" on one:
> ##listen 208.212.80.82
> localip 172.16.1.200
> remoteip 172.16.1.201-250
> pidfile /var/run/pptpd.pid
> 
> Como você pôde ver, meu cliente pegou o IP 172.16.1.201, e meu servidor do
> lado de lá tem o ip 172.16.1.200 ....
> 
> Fazendo minha conexão, dando um ipconfig eu obtenho:
> 
> Ipconfig - XP
> PPP adapter NEB:
> 
>        Connection-specific DNS Suffix  . :
>        Description . . . . . . . . . . . : WAN (PPP/SLIP) Interface
>        Physical Address. . . . . . . . . : 00-53-45-00-00-00
>        Dhcp Enabled. . . . . . . . . . . : No
>        IP Address. . . . . . . . . . . . : 172.16.1.201
>        Subnet Mask . . . . . . . . . . . : 255.255.255.255
>        Default Gateway . . . . . . . . . :
>        DNS Servers . . . . . . . . . . . : 172.16.1.3
>        Primary WINS Server . . . . . . . : 172.16.1.3
> 
> Na tabela de roteamento do windows: (so coloquei a linha importante ok?)
> 
> route print:
> ----------------------------------------------------------
> Active Routes:
> Network Destination        Netmask          Gateway       Interface  Metric
>       172.16.0.0      255.255.0.0     172.16.1.201    172.16.1.201       1
>     172.16.1.201  255.255.255.255        127.0.0.1       127.0.0.1       50
> 
> E por fim um ping para a rede "do outro lado":
> 
> ping 172.16.1.3
> 
> Pinging 172.16.1.3 with 32 bytes of data:
> 
> Reply from 172.16.1.3: bytes=32 time=84ms TTL=127
> 
> > -----Mensagem original-----
> > De: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED] Em nome
> > de R. Filippus
> > Enviada em: quinta-feira, 3 de fevereiro de 2005 14:03
> > Para: freebsd@fug.com.br
> > Assunto: Re: RES: RES: RES: RES: [FUG-BR] poptop + pf
> >
> > Eu observei que ele esta recebendo os mesmos ips para o gateway e para
> > a interface de rede.
> >
> > Endereço IP: 192.2168.250.214
> > Mascara: 255.255.255.255
> > Gateway: 192.168.250.214
> >
> > Tem como eu setar um gateway padrão para os clients?
> >
> 
> _______________________________________________________________
> Para enviar um novo email para a lista: freebsd@fug.com.br
> Sair da Lista: http://mail.fug.com.br/mailman/listinfo/freebsd_fug.com.br
> Historico: http://www4.fugspbr.org/lista/html/FUG-BR/
>

_______________________________________________________________
Para enviar um novo email para a lista: freebsd@fug.com.br
Sair da Lista: http://mail.fug.com.br/mailman/listinfo/freebsd_fug.com.br
Historico: http://www4.fugspbr.org/lista/html/FUG-BR/

Responder a