pessoal estou com um notebook toshiba A60-S1961ST e estou tendo
        problemas com som e wireless, estou usando a versao 5.4 de
        ontem, fiz um
        cvsup.
        
        # uname -a
        
        FreeBSD satellite.nucleolivre.com.br 5.4-STABLE FreeBSD
        5.4-STABLE #4:
        Wed Jun 15 00:18:28 BRT 2005     root at
        satellite.nucleolivre.com.br:/usr/obj/usr/src/sys/DELVIN  i386
        
        segue ai alguma coisa do pciconf -lv
        
        [EMAIL PROTECTED]:20:5:        class=0x040100 card=0xff101179
        chip=0x43411002
        rev=0x00 hdr=0x00
            vendor   = 'ATI Technologies Inc'
            device   = 'AD1981 AC'97 Audio Controller'
            class    = multimedia
            subclass = audio
        [EMAIL PROTECTED]:20:6:        class=0x070300 card=0x00011179
        chip=0x434d1002
        rev=0x01 hdr=0x00
            vendor   = 'ATI Technologies Inc'
            device   = '??? Modem device'
            class    = simple comms
            subclass = generic modem
        [EMAIL PROTECTED]:4:0:  class=0x020000 card=0x7084144f chip=0x0013168c
        rev=0x01
        hdr=0x00
            vendor   = 'Atheros Communications Inc.'
            device   = 'AR5212, AR5213 802.11a/b/g Wireless Adapter'
            class    = network
            subclass = ethernet
        
        como podem ver aparece tudo ali, eu so deixei o modem no meio pq
        vai ser
        outro problema mais pra frente.
        
        agora vao as partes do dmesg:
        
        sobre o wireless:
        
        ath0: <Atheros 5212> mem 0xd0010000-0xd001ffff irq 17 at device
        4.0 on
        pci2
        ath0: unable to attach hardware; HAL status 13
        device_attach: ath0 attach returned 6
        
        pelo q andei vendo o hal status 13 eh pq nao foi reconhecido o
        modelo,
        mais to na dispo de alterar o driver pra ter suporte.
        
        agora o audio:
        
        pci0: <multimedia, audio> at device 20.5 (no driver attached)
        
        agora o cat /dev/sndstat
        
        FreeBSD Audio Driver (newpcm)
        Installed devices:
        
        
        ja fiz um monte de alteracoes no driver de audio mais nao
        resolveu nada,
        sera q alguem tem alguma dica de quais arquivos posso mudar.
        
        ja mexi nesses aki:
        
        /usr/src/sys/dev/sound/pcm/a97.c
        
        e dentro do /usr/src/sys/dev/ath/ nao achei nada de
        interessante.
        
        bem ja escrevi bastate, to precisando de uma ajudinha nisso,
        valeu
        pessoal.


_______________________________________________
Freebsd mailing list
Freebsd@fug.com.br
http://mail.fug.com.br/mailman/listinfo/freebsd_fug.com.br

Responder a