On 3/24/06, Flávio Barros <[EMAIL PROTECTED]> wrote:
> Pessoal, ainda estou com problemas para o php 5 reconhecer o Postgresql
> 8.1.3
> Só para relembrar. Instalei os seguintes aplicativos pelos ports na
> sequência abaixo:
>
> Apache-22
> Php5
> php5-extensions com suporte a postgresql (ELE INSTALOU O CLIENTE PARA O
> POSTGRESQL 7.4)
> Postgresql 8.1.3
> Até tudo uma maravilha. Foi quando fui instalar o postgresql 8.1, tb
> pelos ports. apareceu uma mensagem dizendo que client para postgresql
> 7.4 já estava instalado. O que eu fiz ? Desinstalei o client para
> postgresql 7.4 e instalei o client para postgresql 8.1
> Só que agora o php não está mais com o suporte ao postgresql.
>
>
> Fiz que os colegas da lista me sugeriram mas não funcionou.
> Resolvi fazer o seguinte. Desinstalei tudo menos o Apache22 e instalei a
> seguinte sequência:
>
> Postgresql 8.1.3
> Php5
> php5-extensions com suporte a postgresql
>
> Não deu certo. O suporte ao pgsql não funcionou. E olha que durante a
> compilação do php5-extensions conforme pode ser observado nas mensagens
> abaixo:
>
> ==>   php5-extensions-1.0 depends on file:
> /usr/local/lib/php/20050922/pdo.so - found
> ===>   php5-extensions-1.0 depends on file:
> /usr/local/lib/php/20050922/pgsql.so - found
>
> Analisando melhor a situação encontrei o seguinte problema:
>
> NO /usr/local/etc/php/extensions.ini aparece a entrada  para a lib do
> pgsql conforme abaixo::
> extension=pgsql.so
>
> Executei um find só para tirar confirmar a existência da lib:
> # find / -name "pgsql.so"
> /usr/local/lib/php/20050922/pgsql.so
>
> Foi quando resolvi executar um ldd. Vejam o resultado:
> # ldd /usr/local/lib/php/20050922/pgsql.so
>
> /usr/local/lib/php/20050922/pgsql.so:
>
>         libpq.so.3 => not found (0x0)
>
> O que fiz: Criei um link conforme a linha abaixo.
>
> # ln -s libpq.so.4 libpq.so.3
>
> # ldconfig
>
>  Ao executar phpinfo() agora aparace o suporte ao pgsql, mas ao
> Postgreslq 7.4.12 e não ao  8.1.3.
>
>
>
>  Em outro servidor postgresql que tenho aparece o seguinte:
>
> # ldd /usr/local/lib/php/20050922/pgsql.so
>
> /usr/local/lib/php/20050922/pgsql.so:
>
>         libpq.so.4 => /usr/local/lib/libpq.so.4 (0x28164000)
>
>         libintl.so.6 => /usr/local/lib/libintl.so.6 (0x2817d000)
>
>         libssl.so.4 => /usr/lib/libssl.so.4 (0x28186000)
>
>         libcrypto.so.4 => /lib/libcrypto.so.4 (0x281b4000)
>
>         libcrypt.so.3 => /lib/libcrypt.so.3 (0x282a6000)
>
>         libiconv.so.3 => /usr/local/lib/libiconv.so.3 (0x282be000)
>
> O que pode ser isso ?
> Alguém tem uma luz ?

Observer isso

[EMAIL PROTECTED]:/usr/ports/databases/php5-pgsql# make -V LIB_DEPENDS
pq.3:/usr/ports/databases/postgresql74-client
[EMAIL PROTECTED]:/usr/ports/databases/php5-pgsql# make DEFAULT_PGSQL_VER=81
-V LIB_DEPENDS
pq.4:/usr/ports/databases/postgresql81-client

Percebeu que quando a variavel DEFAULT_PGSQL_VER foi setada pra 81 ele
passou a requerer a versao correta?

Entao faca assim, remove o port php5-pgsql, confirme se o postgres ta
instalado corretamente, versao 8.1 client e server, se estiver
adicione essa linha no arquivo /etc/make.conf

DEFAULT_PGSQL_VER=81

depois disso:

# cd /usr/ports/databases/php5-pgsql && make clean && make install clean

Deve resolver.
--
Renato Botelho
_______________________________________________
freebsd mailing list
freebsd@fug.com.br
http://lists.fug.com.br/listinfo.cgi/freebsd-fug.com.br

Responder a