Olá,

Eu estou rodando FreeBSD 4.11, atualizei o OpenSSL compilando o código
fonte (usei ./config --prefix=/usr --openssldir=/usr/include/openssl
-- não tenho nem certeza se esses paths estão corretos em relação à
versão que eu tinha instalada antes) e então atualizei o Apache e o
PHP, o que me trouxe então erros (Apache não iniciava). Tive que
recompilar ambos removendo a diretiva --use-ssl.

Também encontrei erros enquanto tentava recompilar pelo código fonte o
OpenSSH, dizia que não conseguia encontrar as libs. Embora eu não
precise de ajuda para atualizar o OpenSSH no momento, eu quero agora
remover essa instalação do OpenSSL e usar o sistema de ports. É
possível remover completamente essa instalação mal feita?

Me falaram que se eu usar o ports para reinstalar o OpenSSL, ele vai
remover/sobrescrever minhas duas antigas instalações. Isto está
correto?

E este procedimento abaixo, é assim que eu devo fazer para atualizar pelo ports?

cd /usr/ports/security/openssl
make -DOPENSSL_OVERWRITE_BASE install clean

Depois de resolver isso, recompilarei o Apache e o PHP.

Obrigado.

Francisco

-------------------------
Histórico: http://www.fug.com.br/historico/html/freebsd/
Sair da lista: https://www.fug.com.br/mailman/listinfo/freebsd

Responder a