Corrigindo o conteúdo de .qmail-default:

| /usr/local/bin/maildrop
-M /usr/local/vpopmail/domains/dominio.com.br/mailfilter [1]

[1] Sem a quebra de linha.

Em Qui, 2007-02-08 às 09:49 -0200, Bruno Henrique de Oliveira escreveu:
> Bom dia,
> 
> Realmente não tenho mais idéias do que pode ser feito para resolver meu
> problema, vou colocar mais algumas informações caso alguém tenha alguma
> idéia.
> 
> Dentro do diretório /usr/local/vpopmail/domains/dominio.com.br/ tenho
> dois arquivos o .qmail-default com o conteúdo:
> 
> | /usr/local/bin/maildrop
> -M /usr/local/vpopmail/domains/eacsoftware.com.br/mailfilter [1]
> 
> E um outro arquivo, o mailfilter com o conteúdo:
> 
> import EXT
> import HOST
> 
> SHELL="/usr/local/bin/bash"
> 
> VPOP="| /usr/local/vpopmail/bin/vdelivermail '' bounce-no-mailbox"
> VHOME=`/usr/local/vpopmail/bin/vuserinfo -d [EMAIL PROTECTED]
> 
> logfile /var/log/maildrop.log
> log "Iniciando o maildrop ..."
> xfilter "/usr/local/bin/spamc -f -u [EMAIL PROTECTED]"
> if (/^X-Spam-Flag: *YES/)
> {
> log "Iniciando entrega de spam ..."
>         `test -d $VHOME/Maildir/.Spam`
>                 if ( $RETURNCODE == 1 )
>                 {
>                 log "Criando pasta .Spam do usuario ..."
>                 `/usr/local/bin/maildirmake -f Spam $VHOME/Maildir`
>                 log "Pasta .Spam criada com sucesso."
>                 to "$VHOME/Maildir/.Spam/"
>                 }
>                 else
>                 {
>                 to "$VHOME/Maildir/.Spam/"
>                 log "Entrega de spam concluida."
>                 }
> else
> {
> log "Iniciando entrega de e-mail ..."
> to "$VPOP"
> log "Entrega de e-mail concluida."
> }
> 
> Somente esses dois arquivos foram alterados para utilizar o maildrop. Os
> arquivos e o maildrop estão como "-rw------- vpopmail vchkpw", pelo
> menos os arquivos estão assim, o maildrop esta "-rwsr-sr-x 1 vpopmail
> vchkpw".
> 
> Desde já agradeço.
> 
> Att Bruno Henrique de Oliveira. 
> 
> Em Qua, 2007-02-07 às 17:13 -0200, Bruno Henrique de Oliveira escreveu:
> > Boa tarde,
> > 
> > Desculpa a mensagem fora do tópico, o motivo é que estou tentando
> > configurar o maildrop no vpopmail como foi indicado em outro e-mail
> > nessa lista. Já verifiquei no google e não encontrei nada que ajudou.
> > 
> > Bem, o problema é que quando um e-mail passa pelo meu servidor a
> > seguinte mensagem de erro e postada no maillog:
> > 
> > Feb  7 17:04:30 mailserver maildrop[825]: Home directory owned by wrong
> > user.
> > 
> > Estou tentando comfigurar o maildrop para filtrar os e-mails em conjunto
> > com o vpopmail, alguém poderia me ajudar ?
> > 
> > Desde já agradeço a compreensão.
> > 
> > Att Bruno Henrique de Oliveira.
> > 
> > -------------------------
> > Histórico: http://www.fug.com.br/historico/html/freebsd/
> > Sair da lista: https://www.fug.com.br/mailman/listinfo/freebsd
> 
> -------------------------
> Histórico: http://www.fug.com.br/historico/html/freebsd/
> Sair da lista: https://www.fug.com.br/mailman/listinfo/freebsd

-------------------------
Histórico: http://www.fug.com.br/historico/html/freebsd/
Sair da lista: https://www.fug.com.br/mailman/listinfo/freebsd

Responder a