2010/1/7 Nilton Jose Rizzo <ri...@i805.com.br>:
> On Mon, 4 Jan 2010 23:28:34 -0200, Cleyton Agapito wrote
>> 2010/1/4 Pablo Sánchez <phack...@gmail.com>:
>> > Marcar como OFF na próxima.
>> >
>>
>> Não é off já que até onde eu soube o FreeBSD e MacOS (Darwin) não
>> estão funcionando, windows e linux estão.
>>
>> Ah, eu particularmente odeio top posting...
>
>   Não há coisa pior do que ler a resposta antes da pergunta é uma coisa
>   meio doida mesmo ... e o pior que está na recomendação do uso da lista!
>>
>> > O plugin está instalado no Firefox ou no navegador que vc está usando?
>> >
>>
>> Como ja disse testei no Firefox35, Opera, Epiphany e Konqueror.
>>
>> > Abra seu navegador e acesse o endereço "about:plugins"
>> >
>>
>> Também verifiquei isso em todos os navegadores que testei.
>>
>> > Instale o DIABLO! Esse é o Java que serve para o FreeBSD:
>> >
>>
>> Até onde eu andei lendo (descupe, não lembro onde) o diablo era a
>> versão empacotada do java/jdk16.
>>
>> >
>> > Finish him! :-P
>> >
>>
>> Só mais uma coisa, você (ou alguém) consegue acessar o BB com o
>> diablo? Poderia(m) por gentileza confirmar isso?
>
>   Eu sempre usei o diablo, mas existem bancos que não funcionam em outro
>   sistema sem ser MicroShit  .. Tenho sérios problemas com o Unibanco, HSBC
>   e agora infelismente com o BB.  Quando eu liguei a ultima vez para o
>   suporte do Unibanco ( uns dois anos atras) eles disseram que não suportavam
>   qualquer outra plataforma se não Windows/IE ... e tem gente que acredita
>   que o mundo se resume a isso ..... pois bem agora o BB faz essa P*****A
>   conosco .... e a ultima vez que eu ligue disseram que era possivelmente
>   a versão do Java ... provavelmente a Java da Micro$hit infelismete, pois
>   é bem provavel que tenha sido a mesma empresa que fez a do Unibanco e
>   HSBC ARG   ...... <FLAME>Morram programadores Visuais .......</FLAME>
>
>>
>> Abração!!
>
> --
> Nilton José Rizzo
> 805 Informatica
> Disseminando tecnologias
> 021 2413 9786
>

Talvez o problema não seja a versão do java. Aqui eu utilizo Firefox
3.5.6 em Linux e está funcionando normalmente, mas por curiosidade, eu
fui olhar na lista de arquivos em cache do java (comando javaws
-viewer, os arquivos ficam em .java/deployment/cache/*) e dois
arquivos baixados do site do BB me chamaram a atenção: GbAs.jar e
gbas.so.
O GbAs.jar eu só consegui encontrar no disco fazendo um grep -r na
pasta de cache do java, e o gbas.so eu encontrei na pasta home com um
"." no inicio do nome do arquivo (~/.gbas.so). Esses dois arquivos,
imagino eu, devem ser a tal "solução de segurança" do BB.
O gbas.so é na verdade um arquivo zip, que foi descompactado com o
home ~/.gbas.so_u. Fazendo um file neles, obtenho:

[ ~]$ file .gbas.so
.gbas.so: Zip archive data, at least v2.0 to extract
[ ~]$ file .gbas.so_u
.gbas.so_u: ELF 32-bit LSB shared object, Intel 80386, version 1
(SYSV), dynamically linked, stripped
[ ~]$

Pode ser que o problema de acesso do BB no FreeBSD seja exatamente a
necessidade dessa biblioteca e por ela ter sido feita para linux.
Talvez seja possível funcionar com a compatibilidade binária ativada.
Talvez seja necessário também utilizar o plugin do java para Linux com
compatibilidade binária ativada, como é feito para o plugin do flash.
São suposições, mas acho que isso dá outro rumo à procura da solução.
-------------------------
Histórico: http://www.fug.com.br/historico/html/freebsd/
Sair da lista: https://www.fug.com.br/mailman/listinfo/freebsd

Responder a