Вот захотелось мне получить, например, py35-scipy. Записи в make.conf
вида

DEFAULT_VERSIONS= python3=3.5
DEFAULT_VERSIONS+=  python=3

не помогают - продолжает собираться py27-scipy, как по умолчанию.
И python=3.5 писать - аналогично. Потому, к "default versions" на её
вики не посылать - не оно.

Можно в конкретный Makefile вписать: заменить USES=python на
USES=python:3. Хак, однако.
Можно то же через make.conf или Makefile.local - точно так же грязно.

Можно выставить для make: make USES=python:3 ... Так работает, но уже
в окружение (чтобы какой-нибудь portmaster подхватил) - нельзя: не
видит на первом же уровне (env USES=python:3 make - не работает).

Есть ли кошерный метод?

(В гугле был, сплошные инструкции для майнтейнеров портов - не
радуют.)


-netch-
_______________________________________________
freebsd mailing list
freebsd@uafug.org.ua
http://mailman.uafug.org.ua/mailman/listinfo/freebsd

Ответить