Author: sveinung
Date: Fri Aug 28 12:55:56 2015
New Revision: 29707

URL: http://svn.gna.org/viewcvs/freeciv?rev=29707&view=rev
Log:
Make 7.12.1 the minimum CURL version

and document what CURL version is required in INSTALL

See bug #23824

Modified:
    branches/S2_5/INSTALL
    branches/S2_5/configure.ac
    branches/S2_5/doc/README.packaging

Modified: branches/S2_5/INSTALL
URL: 
http://svn.gna.org/viewcvs/freeciv/branches/S2_5/INSTALL?rev=29707&r1=29706&r2=29707&view=diff
==============================================================================
--- branches/S2_5/INSTALL       (original)
+++ branches/S2_5/INSTALL       Fri Aug 28 12:55:56 2015
@@ -73,7 +73,7 @@
 
    The output should include "GNU Make" somewhere.
 
- - libcurl
+ - libcurl version 7.12.1 or better
 
    Libcurl takes care of http communication with the metaserver, and
    file transfers of modpack installers

Modified: branches/S2_5/configure.ac
URL: 
http://svn.gna.org/viewcvs/freeciv/branches/S2_5/configure.ac?rev=29707&r1=29706&r2=29707&view=diff
==============================================================================
--- branches/S2_5/configure.ac  (original)
+++ branches/S2_5/configure.ac  Fri Aug 28 12:55:56 2015
@@ -607,7 +607,7 @@
 if test "x$PKG_CONFIG" = "x" ; then
   AC_MSG_ERROR([pkg-config not found])
 fi
-PKG_CHECK_MODULES([CURL], [libcurl >= 7.9.7],,
+PKG_CHECK_MODULES([CURL], [libcurl >= 7.12.1],,
     [AC_MSG_ERROR([libcurl development files required])])
 UTILITY_CFLAGS="${UTILITY_CFLAGS} ${CURL_CFLAGS}"
 UTILITY_LIBS="${UTILITY_LIBS} ${CURL_LIBS}"

Modified: branches/S2_5/doc/README.packaging
URL: 
http://svn.gna.org/viewcvs/freeciv/branches/S2_5/doc/README.packaging?rev=29707&r1=29706&r2=29707&view=diff
==============================================================================
--- branches/S2_5/doc/README.packaging  (original)
+++ branches/S2_5/doc/README.packaging  Fri Aug 28 12:55:56 2015
@@ -47,6 +47,7 @@
   of freeciv-manual tool that's mostly useless for normal users.
 * Qt-client is now supported client, no longer just "in-development"
 * Xaw-client is no longer considered maintained client
+* Minimum libcurl version is now 7.12.1
 
 ----------------------------------------------------------------------
 Compatibility of modified versions


_______________________________________________
Freeciv-commits mailing list
Freeciv-commits@gna.org
https://mail.gna.org/listinfo/freeciv-commits

Reply via email to