Author: cazfi
Date: Wed Oct 14 17:51:45 2015
New Revision: 30077

URL: http://svn.gna.org/viewcvs/freeciv?rev=30077&view=rev
Log:
Made version 2.2 the minimum libtool requirement.

See patch #6414

Modified:
    trunk/INSTALL
    trunk/autogen.sh
    trunk/configure.ac
    trunk/doc/README.packaging

Modified: trunk/INSTALL
URL: 
http://svn.gna.org/viewcvs/freeciv/trunk/INSTALL?rev=30077&r1=30076&r2=30077&view=diff
==============================================================================
--- trunk/INSTALL       (original)
+++ trunk/INSTALL       Wed Oct 14 17:51:45 2015
@@ -4,7 +4,7 @@
 
 This file describes how to compile and install Freeciv. Last time we
 made sure this file is up to date was 16-Jul-06.
-Last minor update was 31-Jul-15.
+Last minor update was 14-Oct-15.
 
 There may be a localized version of this file in the ./doc directory,
 named INSTALL.<locale> (e.g., INSTALL.de).
@@ -73,6 +73,8 @@
 
    The output should include "GNU Make" somewhere.
 
+ - libtool version 2.2 or better
+
  - libcurl version 7.15.4 or better
 
    Libcurl takes care of http communication with the metaserver, and

Modified: trunk/autogen.sh
URL: 
http://svn.gna.org/viewcvs/freeciv/trunk/autogen.sh?rev=30077&r1=30076&r2=30077&view=diff
==============================================================================
--- trunk/autogen.sh    (original)
+++ trunk/autogen.sh    Wed Oct 14 17:51:45 2015
@@ -237,7 +237,7 @@
 AUTOMAKE=$REALPKGNAME
 real_package_name "aclocal" "ftp://ftp.gnu.org/pub/gnu/automake/"; 1 11 || DIE=1
 ACLOCAL=$REALPKGNAME
-real_package_name "libtoolize" "ftp://ftp.gnu.org/pub/gnu/libtool/"; 1 5 2 || 
DIE=1
+real_package_name "libtoolize" "ftp://ftp.gnu.org/pub/gnu/libtool/"; 2 2 || 
DIE=1
 LIBTOOLIZE=$REALPKGNAME
 
 if [ "$FC_USE_NLS" = "yes" ]; then

Modified: trunk/configure.ac
URL: 
http://svn.gna.org/viewcvs/freeciv/trunk/configure.ac?rev=30077&r1=30076&r2=30077&view=diff
==============================================================================
--- trunk/configure.ac  (original)
+++ trunk/configure.ac  Wed Oct 14 17:51:45 2015
@@ -483,11 +483,7 @@
 AC_PROG_CPP
 AC_PROG_LN_S
 AC_DISABLE_SHARED
-dnl Replace AC_PROG_LIBTOOL with LT_INIT when minimum libtool
-dnl version 2.2
-AC_PROG_LIBTOOL
-LIBTOOL="$LIBTOOL --preserve-dup-deps"
-AC_SUBST(LIBTOOL)
+LT_INIT
 AC_CHECK_TOOL(AR, ar)
 if test -z $AR; then
        AC_MSG_ERROR([*** 'ar' missing.  Install binutils, fix your \$PATH, or 
set \$AR manually. ***])

Modified: trunk/doc/README.packaging
URL: 
http://svn.gna.org/viewcvs/freeciv/trunk/doc/README.packaging?rev=30077&r1=30076&r2=30077&view=diff
==============================================================================
--- trunk/doc/README.packaging  (original)
+++ trunk/doc/README.packaging  Wed Oct 14 17:51:45 2015
@@ -27,6 +27,7 @@
   See chapter "Project definition file" below.
 * Xaw-client has been dropped completely
 * Minimum libcurl version is now 7.15.4
+* Minimum libtool version is now 2.2
 
 ----------------------------------------------------------------------
 Compatibility of modified versions


_______________________________________________
Freeciv-commits mailing list
Freeciv-commits@gna.org
https://mail.gna.org/listinfo/freeciv-commits

Reply via email to