Author: cazfi
Date: Fri Jan 29 00:30:21 2016
New Revision: 31659

URL: http://svn.gna.org/viewcvs/freeciv?rev=31659&view=rev
Log:
Updated README.msys2

See patch #6848

Modified:
    branches/S2_6/doc/README.msys2

Modified: branches/S2_6/doc/README.msys2
URL: 
http://svn.gna.org/viewcvs/freeciv/branches/S2_6/doc/README.msys2?rev=31659&r1=31658&r2=31659&view=diff
==============================================================================
--- branches/S2_6/doc/README.msys2      (original)
+++ branches/S2_6/doc/README.msys2      Fri Jan 29 00:30:21 2016
@@ -1,6 +1,6 @@
 
-MSYS2 Windows Installer build notes
-===================================
+ MSYS2 Windows Installer build notes
+====================================
 
 MSYS2 support is still Work In Progress!
 These are the notes so far, not yet documentation of working
@@ -9,9 +9,23 @@
 This document is about building Freeciv Windows Installer packages
 using MSYS2 from http://msys2.github.io
 
+
+ Status
+====================================
+
+- With very specific configure options (see Problems) and msys2 package
+  selection freeciv can be built. This includes the server and gtk3-client
+- Both server and client launch ok
+- Client cannot connect to the server
+- Installers cannot be built
+
+
+ Setup
+====================================
+
 1) Install MSYS2 following the documentation on their homepage
 
-2) Install following packages with 'pacman -S'
+2) Install following packages with 'pacman -Su'
 
 2.1) Packages needed for building freeciv
  These packages are needed even if you don't plan to make installer,
@@ -28,7 +42,6 @@
  - libsqlite-devel
  - libiconv-devel
  - pkg-config
- - libreadline-devel
  - libbz2-devel
  - libcurl-devel
  - liblzma-devel
@@ -39,13 +52,32 @@
  - mingw-w64-i686-nsis / mingw-w64-x86_64-nsis
 
 
-TODO:
+Packages TODO:
  - Mixer support
+ - Clients other than gtk3
+ - MagickWand support
+
 
 3) Build Installers from Freeciv sources
 > cd win32/installer_msys2
-> make
+> make <targets>
 
+  Target can be:
+  - "<gui>-installer", where <gui> is
+     - gtk3
+
+
+Problems
+====================================
+
+- Freeciv linked against readline in msys2 does not work.
+  Either avoid installing libreadline-devel package to your msys2
+  environment at all, or configure freeciv with --without-readline
+
+- Freeciv with Native Language Support does not build.
+  Use configure option --disable-nls
+
+====================================
 
 Instructions used with msys1 below. These need to be updated:
 - pacman used instead of hg


_______________________________________________
Freeciv-commits mailing list
Freeciv-commits@gna.org
https://mail.gna.org/listinfo/freeciv-commits

Reply via email to