Author: cazfi
Date: Tue May 10 23:06:20 2016
New Revision: 32655

URL: http://svn.gna.org/viewcvs/freeciv?rev=32655&view=rev
Log:
Made gtk+ 3.10 minimum requirement for gtk3-client

See patch #7203

Modified:
    trunk/INSTALL
    trunk/configure.ac
    trunk/doc/README.packaging
    trunk/m4/gtk3-client.m4

Modified: trunk/INSTALL
URL: 
http://svn.gna.org/viewcvs/freeciv/trunk/INSTALL?rev=32655&r1=32654&r2=32655&view=diff
==============================================================================
--- trunk/INSTALL       (original)
+++ trunk/INSTALL       Tue May 10 23:06:20 2016
@@ -248,7 +248,7 @@
        Provides an abstraction layer over X-Windows/LinuxFB/Win32 to implement
        basic drawing functions, windows, clipping, etc.
 
-   Freeciv requires a version of "Gtk+" greater or equal to 3.8.0.
+   Freeciv requires a version of "Gtk+" greater or equal to 3.10.0.
 
    If the Freeciv configure process tells you that you don't have the
    Gtk+ library installed, then it may be obtained from here:

Modified: trunk/configure.ac
URL: 
http://svn.gna.org/viewcvs/freeciv/trunk/configure.ac?rev=32655&r1=32654&r2=32655&view=diff
==============================================================================
--- trunk/configure.ac  (original)
+++ trunk/configure.ac  Tue May 10 23:06:20 2016
@@ -1038,9 +1038,9 @@
 
 if test "x$req_fcmp_gtk3" = "xyes" ||
    test "x$modinst" = "xall" || test "x$modinst" = "xauto" ; then
-  PKG_CHECK_MODULES([GTK3MP], [gtk+-3.0 >= 3.8.0],
+  PKG_CHECK_MODULES([GTK3MP], [gtk+-3.0 >= 3.10.0],
 [
-  GTK3MP_CFLAGS="$GTK3MP_CFLAGS -DGDK_VERSION_MIN_REQUIRED=GDK_VERSION_3_8 
-DGDK_VERSION_MAX_ALLOWED=GDK_VERSION_3_8"
+  GTK3MP_CFLAGS="$GTK3MP_CFLAGS -DGDK_VERSION_MIN_REQUIRED=GDK_VERSION_3_8 
-DGDK_VERSION_MAX_ALLOWED=GDK_VERSION_3_10"
   GTK3MP_CFLAGS="$GTK3MP_CFLAGS -DGLIB_VERSION_MIN_REQUIRED=GLIB_VERSION_2_36 
-DGLIB_VERSION_MAX_ALLOWED=GLIB_VERSION_2_36"
   PKG_CHECK_MODULES([GTHREAD_GTK3], [gthread-2.0],
 [

Modified: trunk/doc/README.packaging
URL: 
http://svn.gna.org/viewcvs/freeciv/trunk/doc/README.packaging?rev=32655&r1=32654&r2=32655&view=diff
==============================================================================
--- trunk/doc/README.packaging  (original)
+++ trunk/doc/README.packaging  Tue May 10 23:06:20 2016
@@ -29,6 +29,7 @@
 * Sdl-client has been dropped completely
 * Minimum libcurl version is now 7.15.4
 * Minimum libtool version is now 2.2
+* Minimum gtk3 requirement for building gtk3-client is now 3.10
 * Added gtk3x-client. The difference between gtk3-client and gtk3x-client is
   that latter is adjusted for, and depends on, as new gtk3 version as
   possible. Once gtk4 gets released, this client is turned to gtk4-client.

Modified: trunk/m4/gtk3-client.m4
URL: 
http://svn.gna.org/viewcvs/freeciv/trunk/m4/gtk3-client.m4?rev=32655&r1=32654&r2=32655&view=diff
==============================================================================
--- trunk/m4/gtk3-client.m4     (original)
+++ trunk/m4/gtk3-client.m4     Tue May 10 23:06:20 2016
@@ -7,9 +7,9 @@
 [
   if test "x$gui_gtk3" = "xyes" || test "x$client" = "xauto" ||
      test "x$client" = "xall" ; then
-    PKG_CHECK_MODULES([GTK3], [gtk+-3.0 >= 3.8.0],
+    PKG_CHECK_MODULES([GTK3], [gtk+-3.0 >= 3.10.0],
       [
-        GTK3_CFLAGS="$GTK3_CFLAGS -DGDK_VERSION_MIN_REQUIRED=GDK_VERSION_3_8 
-DGDK_VERSION_MAX_ALLOWED=GDK_VERSION_3_8"
+        GTK3_CFLAGS="$GTK3_CFLAGS -DGDK_VERSION_MIN_REQUIRED=GDK_VERSION_3_8 
-DGDK_VERSION_MAX_ALLOWED=GDK_VERSION_3_10"
         GTK3_CFLAGS="$GTK3_CFLAGS 
-DGLIB_VERSION_MIN_REQUIRED=GLIB_VERSION_2_36 
-DGLIB_VERSION_MAX_ALLOWED=GLIB_VERSION_2_36"
         gui_gtk3=yes
         if test "x$client" = "xauto" ; then


_______________________________________________
Freeciv-commits mailing list
Freeciv-commits@gna.org
https://mail.gna.org/listinfo/freeciv-commits

Reply via email to