Author: cazfi
Date: Wed Jul 27 09:55:31 2016
New Revision: 33333

URL: http://svn.gna.org/viewcvs/freeciv?rev=33333&view=rev
Log:
Updated README.msys2:
- Updated msys2 work status
- Removed msys1 related notes
- Some other minor fixes

See patch #7511

Modified:
    trunk/doc/README.msys2

Modified: trunk/doc/README.msys2
URL: 
http://svn.gna.org/viewcvs/freeciv/trunk/doc/README.msys2?rev=33333&r1=33332&r2=33333&view=diff
==============================================================================
--- trunk/doc/README.msys2      (original)
+++ trunk/doc/README.msys2      Wed Jul 27 09:55:31 2016
@@ -1,10 +1,6 @@
 
  MSYS2 Windows Installer build notes
 ====================================
-
-MSYS2 support is still Work In Progress!
-These are the notes so far, not yet documentation of working
-build.
 
 This document is about building Freeciv Windows Installer packages
 using MSYS2 from http://msys2.github.io
@@ -13,6 +9,8 @@
  Status
 ====================================
 
+- Msys1, not msys2, is still the official freeciv Windows Installer
+  build method
 - With very specific configure options (see Problems) and msys2 package
   selection freeciv can be built
 - Buildable clients are gtk3 and Qt
@@ -85,7 +83,7 @@
  - tar
 
 2.1.1.3) Arch independent packages needed for building freeciv from svn 
checkout
- These are needed in addition to the ones alwaysneeded for building freeciv.
+ These are needed in addition to the ones always needed for building freeciv.
 
  - subversion
  - automake
@@ -189,6 +187,7 @@
      - gtk3
      - qt
   - "ruledit-installer"
+  - "snapshot", if your freeciv sources are in svn checkout directory
 
  You can also set minimum Windows version targeted. While setting this
  to an older version allows those Windows versions to run the created
@@ -196,7 +195,7 @@
  newer Windows versions could otherwise have.
  The version is set via MIN_WIN_VER variable. For values to use, see
  list in: https://msdn.microsoft.com/en-us/library/6sehtctf.aspx
- Current default is 0x0600 (Vista).
+ Current default is 0x0600 (Windows Vista).
 
 
  Problems
@@ -232,29 +231,3 @@
   removing any dll's from the installer packages.
   Please review what related dlls are packaged and could be
   removed.
-
-====================================
-
-Instructions used with msys1 below. These need to be updated:
-- pacman used instead of hg
-- has two (win32 and win64) environments instead of just one
-- distribution method of official freeciv environments not decided,
-  currently using what ever versions upstream currently has
-
-
- Usage:
-
- 1. download and extract the MinGW build environment from
-    http://download.gna.org/freeciv/packages/windows/gnuwin32/
-    Current version is gnuwin32-2015-02-25.
- 2. double click on "gnuwin32/msys.bat"
- 3. install the development packages:
-    $ hg qpush -a
- 4. close current session and restart msys.bat. This is required
-    for PATH to be set correctly after development packages
-    installation.
- 5. change into the Freeciv directory where this Makefile resides
-    $ cd <path_to_freeciv_source>/win32/installer
- 6. run make
-    $ make
- 7. find the installer executables in the 'Output' directory


_______________________________________________
Freeciv-commits mailing list
Freeciv-commits@gna.org
https://mail.gna.org/listinfo/freeciv-commits

Reply via email to