<URL: http://bugs.freeciv.org/Ticket/Display.html?id=28534 >

> [EMAIL PROTECTED] - Mo 11. Dez 2006, 09:02:59]:
> 
> Mike McDermott wrote:
> > <URL: http://bugs.freeciv.org/Ticket/Display.html?id=28534 >
> >
> > Hi,
> >
> > I've recently downloaded the 2.1.0 beta2 of freeciv for windows.  I
> can't
> > get it to save games.  The dialog seems to work fine to save the
> game, but
> > after I type in a name for the game and press save no file is
> created on the
> > harddrive.  I tried the same thing with 2.0.8 and it worked fine, so
> I think
> > I'm doing it right (how hard can it be to save a game?)  I still
> have
> > several gigabytes free on the HDD so it's not a full drive.  I'm
> using the
> > default installation and game save directories on Windows XP
> >
> > Any ideas?
> 
> An odd problem.  Most likely I'd guess it's saving the file in the
> wrong
> place, or at least in a different place from where it looks for it
> later.  I seem to recall some changes about home directories under XP,
> it's probably trying to save in your documents folder somewhere.
> 
> I'm not sure how to easily trace the save location however.
> 
> -jason
> 
> 

I just tried to reproduce and it turns out the server has problems
saving a game when the path given to it contains dots. For example:

> save C:\Program Files\Freeciv-2.1.0-beta2-gtk2\civgame-test
Game saved as C:\Program Files\Freeciv-2.sav.gz

if a path without dots or no path at all is given, it works fine:

> save C:\Program Files\Freeciv-2_1_0-beta2-gtk2\civgame-test
Game saved as C:\Program Files\Freeciv-2_1_0-beta2-gtk2\civgame-test.sav.gz

> save civgame-test
Game saved as civgame-test.sav.gz

> save
Game saved as civgame-0400m.sav.gz

But this happens with 2.0.8, too, so I'm not sure if it is the cause of
the problem the ticket creator had. I couldn't find any other problems
with saving in the Windows clients, though.

_______________________________________________
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev

Reply via email to