<URL: http://bugs.freeciv.org/Ticket/Display.html?id=39513 >

 One fix (more required) to toluaxx makefiles.

 - It tried to get built liblua.a from source directory instead of
build directory
 - libluaxx requires lua-5.1, so it will never be used with
liblualib.a. Still it attempted to link against it


 - ML

diff -Nurd -X.diff_ignore freeciv/dependencies/toluaxx/src/bin/Makefile.am freeciv/dependencies/toluaxx/src/bin/Makefile.am
--- freeciv/dependencies/toluaxx/src/bin/Makefile.am	2007-08-06 05:50:57.000000000 +0300
+++ freeciv/dependencies/toluaxx/src/bin/Makefile.am	2007-08-09 12:17:19.000000000 +0300
@@ -43,11 +43,9 @@
 	lua/tlx_verbatim.lua
 
 tolua_DEPENDENCIES = \
-	$(top_srcdir)/dependencies/lua/src/liblua.a \
-	$(top_srcdir)/dependencies/lua/src/lib/liblualib.a \
+	$(top_builddir)/dependencies/lua/src/liblua.a \
 	../lib/libtolua.a
 
 tolua_LDADD = \
-	$(top_srcdir)/dependencies/lua/src/liblua.a \
-	$(top_srcdir)/dependencies/lua/src/lib/liblualib.a \
+	$(top_builddir)/dependencies/lua/src/liblua.a \
 	../lib/libtolua.a -lm
_______________________________________________
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev

Reply via email to