<URL: http://bugs.freeciv.org/Ticket/Display.html?id=19474 >

> [EMAIL PROTECTED] - Mon Aug 14 18:57:39 2006]:
>    BTW the OS is W98SE. 
>    Also I compiled the GTK client on Ubuntu and tried that (both
> 2.1.0b1 and 2.1.0b2).  The problem exists there too - but different
> techs cause the problem there.  On the GTK version of Freeciv
> 2.1.0b2, only Masonry and Pottery cause a crash - a segmentation
> fault.  Writing, Bronze Working, etc. work correctly. 
>    I looked at the techs.ruleset file but I didn't see anything
> wrong with the entries for Masonry, Pottery, Writing, etc.  Could it
> be the graphics associated with those techs?  I tried the game both
> with and without "--tiles isophex" and it crashed the same way both
> times. 
>    FWIW, I compiled the GTK client with "./configure --disable-nls"
> (and "make" of course). 
>  -Eddie 

Do you still experience these crashes in 2.1.0-beta4?

It could very well be related to the graphics associated with the techs,
as you say, since they occur when you try to access the help system. All
default tilesets do have these tech icons enabled, so it wouldn't matter
which one you chose. You could, however, disable them by editing the
tileset's tilespec file (i.e. isophex.tilespec) and remove the line that


To be able to fix the crash, it would be ideal if you could provide a
backtrace for it!


Freeciv-dev mailing list

Reply via email to